Opening a downloaded image on Firefox

When i download an image on Firefox and then open it still inside Firefox in this “download notitification arrow”, it will open it with Okular although i have gwenview assigned to images.
In Dolphin it opens with gwenview naturally.
How can i change so that it open with gwenview too, from Firefox?
I checked the Firefox preferences but could not find it.

Seems to be a firefox bug.
There are settings … but they dont seem to stick.
ex: Change what Firefox does when you click on or download a file | Firefox Help

1 Like

I had a similar problem. Okular has the tendency to associate itself with everything. Under KDE Plasma I fixed this by adjusting the file associations for the respective file type.
For example: Okular once assigned itself as the primary program for .gpg files (which it isn’t, cant even read them). To fix this I opened “file associations” (Application Launcher --> search for “file associations” or System Settings --> Personalization --> Applications --> File Associations) then searched for the file type (“gpg”) and removed okular from the list.
Here is a picture for the last step:

hope that helps

1 Like

I was just staring at my own thread for no reason 11h after i posted when you replied. Couldn’t believe it! :slight_smile: And this actually solved the problem. Thank you very much.
It is strange however that Okular was 2nd in the order of preference and it actually opened with it.
Something maybe the devs have to work on.