Opencl not working after update

Hello everyone I have been using manjaro for about 4 months now on my laptop (x453sa) and everything was great until the last update, now opencl does not work I use svp to watch videos but now if I have installed ocl-icd it wont launch whenever tries to get the gpu info IT crashes with a segmentación error, and I am sure is not svp because before the update worked with gpu acceleration, also clinfo shows the same error what can I do to fix IT? My CPU is a n3050 with Intel HD 400 graphics (braswell) .thanks (disclaimer I dont speak much english and the phone corrector was on the background)


First, I’d advise you to read this:

That could help you to provide better information:

sudo pacman -S manjaro-log-helper


Thanks for the advice, its just that I am currently on a friend phone, I dont have internet on the laptop :frowning_face: I Will try to submit more info when I can. Although IT could be on a New account cuz this is not my phone.

Why can’t you just log onto the same account on a different device instead of making a new account…?

Do you have one of these opencl packages installed for Intel?

i have beignet installed allongside ocl-idc and clinfo, and no i cant log in because i used his mail, by the way as you can see i have an own account now

how do i upload the log of manjaro log helper?

That way please.

Number of platforms                               1
  Platform Name                                   Intel Gen OCL Driver
  Platform Vendor                                 Intel
  Platform Version                                OpenCL 2.0 beignet 1.4 (git-fc5f430c)
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_3d_image_writes cl_khr_image2d_from_buffer cl_khr_depth_images cl_khr_spir cl_khr_icd cl_intel_accelerator cl_intel_subgroups cl_intel_subgroups_short cl_intel_required_subgroup_size cl_intel_media_block_io cl_intel_planar_yuv
  Platform Extensions function suffix             Intel
Violación de segmento (`core' generado)

thats the clinfo log it appears to be the beignet package i tested with pocl and shows the info (but svp dosn’t detect the driver)

FIXEEEED!!! installing the AUR package of beignet 1.3.4 (not beignet-git) fixes everithing.