OpenCL headers/setup for intel i9 cpu?


I have so far managed to get OpenCL up and running on my GTX 760 graphics card, by simply installing the headers found in the AUR. However I have struggled to find headers (or any setup guide) for intel core cpu’s on an arch based system (I run manjaro xfce). I have an i9 10900kf cpu, and when I run clinfo command in the terminal, I get Number of platforms 1 , and my cpu doesn’t show up, only my GTX graphics card does . Is there any information of how to setup opencl for these cpu’s on manjaro/arch?


opencl-headers are in the community repo as an optional dependency of opencl-nvidia & lib32-opencl-nvidia. You should only need those.

What are you installing from the AUR? If it’s intel-opencl, that’s most likely not applicable as it’s a legacy driver for older Intel graphics chips.

Please post your system info as outlined here:

As well as:

pacman -Qs opencl

Yeah, I have the nv repos and CL headers installed, and I’ve been using them to make OpenCL work on my graphics card
But what I now want to know is how to setup OpenCL to run on my CPU, instead of graphics card. But I am not sure what is required to set this up on an arch based system like manjaro (i.e. what repos do I need to install to enable this).

Please post your system info as outlined here:

FYI this is output of the inxi --admin --verbosity=7 --filter --widthcommand:

  Kernel: 5.4.159-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
  root=UUID=0ca58d64-19a6-42fc-82be-35fc4a0cc153 rw quiet udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: TUF GAMING B460M-PLUS v: Rev 1.xx
  serial: <superuser required> UEFI: American Megatrends v: 1101
  date: 01/15/2021
  Message: No system battery data found. Is one present?
  RAM: total: 31.27 GiB used: 2.29 GiB (7.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: 10-Core model: Intel Core i9-10900KF bits: 64 type: MT MCP
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 5 microcode: E2
  cache: L1: 640 KiB L2: 2.5 MiB L3: 20 MiB bogomips: 148040
  Speed: 898 MHz min/max: 800/5300 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800
  14: 800 15: 800 16: 800 17: 800 18: 800 19: 800 20: 800
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
  pku pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
  xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GK104 [GeForce GTX 760] vendor: Gigabyte driver: nvidia
  v: 470.86 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1187
  class-ID: 0300
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
  loaded: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 69 s-size: 707x392mm (27.8x15.4")
  s-diag: 808mm (31.8")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 70 size: 698x393mm (27.5x15.5")
  diag: 801mm (31.5")
  OpenGL: renderer: NVIDIA GeForce GTX 760/PCIe/SSE2 v: 4.6.0 NVIDIA 470.86
  direct render: Yes
  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
  alternate: snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:a3f0 class-ID: 0403
  Device-2: NVIDIA GK104 HDMI Audio vendor: Gigabyte driver: snd_hda_intel
  v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e0a class-ID: 0403
  Sound Server-1: ALSA v: k5.4.159-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k
  port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d55 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8188CUS 802.11n WLAN Adapter type: USB
  driver: rtl8192cu bus-ID: 1-6:4 chip-ID: 0bda:8176 class-ID: 0000
  serial: <filter>
  IF: wlp0s20f0u6 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 83.35 GiB (17.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
  model: WDS500G2B0A-00SM50 size: 465.76 GiB block-size: physical: 512 B
  logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 40WD
  scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 465.47 GiB size: 457.16 GiB (98.22%)
  used: 83.35 GiB (18.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: 0ca58d64-19a6-42fc-82be-35fc4a0cc153
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
  uuid: EE8B-3F57
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Microdia USB DEVICE type: Keyboard,Mouse
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 0c45:7697 class-ID: 0301
  Device-2: 1-4:3 info: Sunplus Innovation Gaming mouse [Philips SPK9304]
  type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 2.0
  speed: 1.5 Mb/s power: 98mA chip-ID: 1bcf:08a0 class-ID: 0301
  Device-3: 1-6:4 info: Realtek RTL8188CUS 802.11n WLAN Adapter type: Network
  driver: rtl8192cu interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 0bda:8176 class-ID: 0000 serial: <filter>
  Hub-2: 1-11:5 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
  power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-11.3:6 info: ASUSTek AURA LED Controller type: HID
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 16mA
  chip-ID: 0b05:1939 class-ID: 0300 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 8 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 34 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 20%
  Processes: 357 Uptime: 1h 33m wakeups: 3 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1321
  lib: 420 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.09

As well as:

pacman -Qs opencl

When I try and run that, I get this:

sudo: invalid option -- 'Q'
usage: sudo -h | -K | -k | -V
usage: sudo -v [-ABknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-ABknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
usage: sudo [-ABbEHknPS] [-C num] [-D directory] [-g group] [-h host] [-p
            prompt] [-R directory] [-T timeout] [-u user] [VAR=value] [-i|-s]
usage: sudo -e [-ABknS] [-C num] [-D directory] [-g group] [-h host] [-p
            prompt] [-R directory] [-T timeout] [-u user] file ...

It appears you would need intel-compute-runtime and should not need anything from the AUR. See GPGPU - ArchWiki

I don’t know what command you ran, but it wasn’t pacman -Qs opencl. Don’t use sudo.

Ok thanks for that. My bad, I ran it as sudo, here is the output:

    Simple OpenCL application that enumerates all available platform and device
local/lib32-ocl-icd 2.3.0-1
    OpenCL ICD Bindings (32-bit)
local/mingw-w64-opencl-headers 2021.06.30-1 (mingw-w64-vulkan-devel)
    OpenCL (Open Computing Language) header files (mingw-w64)
local/mingw-w64-opencl-icd 2021.06.30-1 (mingw-w64-vulkan-devel)
    The OpenCL ICD Loader (mingw-w64)
local/ocl-icd 2.3.1-1
    OpenCL ICD Bindings
local/opencl-clhpp 2.0.15-1
    OpenCL C++ header files
local/opencl-headers 2:2021.04.29-1
    OpenCL (Open Computing Language) header files
local/opencl-nvidia-470xx 470.86-1
    OpenCL implemention for NVIDIA