Open by double click problems

Hi all,
since the latest stable update I have problems running my .desktop files on desktop by double click.

Workspace Behavior is set to
Clicking files or folders: [o] Selects them (Open by doube-clicking instead)

After each login into a Plasma session open by double-clicking does not work. When I temporary switch to open by single-clicking and switch back to open by double-clicking it works until next login. :face_vomiting:

I tried to create a new user to check if this happens with a fresh user session as well. With a fresh user it does not occur.

Has anyone a solution for this without to create a new user?


1 Like


grep "Click" /etc/xdg/kdeglobals

If the output is different from



sudo nano --backup /etc/xdg/kdeglobals

and delete the line that begins with:


and set it to:


Save by Ctrl+X Enter Y

log off and log back and and try again.


I found out that new Application Launcher causes this problem.

When I switch to the basic Application Menu everything works well after login.

So I think I will stay with the basic menu for now. :slight_smile:

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.