Only one monitor working after latest update (11-02-22)

Hello! Last night, I installed the latest Manjaro update (11-02-22). This moved me to the latest kernel (6.0.6-1). I had shut my system down after the update completed because I was done with everything, but when I turned it back on this morning, only one of my monitors was on. I didn’t have time to look into the issue until now.

It was not my monitor labelled as Primary, it was my secondary monitor. I shut my monitors off one at a time, turned them on one at a time, restart my system, and went into my display settings. My primary monitor was disabled, but when I attempted to enable it, my second monitor shifted up with a large black bar under my taskbar and the primary monitor did not turn on.

After testing the options, I also noticed that when I set both monitors to be on, I would get no desktop or apps, but could see my cursor. I managed to get my primary monitor working again, but now my secondary monitor says it has no signal.

I have no clue what could have caused this, I did a proper shutdown after installing the update and when troubleshooting before making this post. They both run using DisplayPort, and I am using a NVIDIA 3070. Is there something I missed when troubleshooting myself?

Hello,

There are a lot of reports about Nvidia GPU’s issues with the latest drivers. Start by enabling early KMS

Then we can go from there, step by step, in case the issue persists.

I tried running sudo mhwd -r pci video-linux and sudo mhwd -i pci video-nvidia, but got config video-linux is not installed! and a version of config video-nvidia is already installed!

I did edit my mkinitcpio.conf and ran the sudo mkinitcpio -P sudo update-grub, but after a restart nothing has changed.

Here is my solution on KDE:
Switch to “Unity outputs” mode, i.e. duplicate mode, both montors work fine.
Then switch to external monitor only mode, it’ll work even after rebooting.

Maybe the problem is plasma related:

in ~/.local/share rename the folder kscreen to kscreen.bak and reboot

1 Like

That was it! I thought it would be more complicated, but in hindsight it would make sense to just generate a new folder. I would have never known where to look though, I’m not completely familiarized with every aspect of the distro. Thank you so much!

UPDATE: I restarted my PC this morning and everything was fine until my monitors went into sleep. I came back and had the same issues as before. My second monitor had a huge black bar that pushed the top 8th of my desktop into unviewable space, and my primary monitor was black.

However, after opening settings and dealing with trying to navigate with a cursor that did not sync with the screen (the image was pushed up but the actions were still in the correct place, if that makes sense), I saw it was disabled again. I re-enabled it, tried moving my cursor to my blacked out monitor, and the desktop on my second screen began to move away from the cursor.

I’m at a loss again, I was so excited when it worked too! It could be something to do with my monitors going into auto-sleep, but I would like to keep that enabled since I do not want burn-in.