ONLY 4K resolution available

Hello together,

so I’m using Manjaro in its KDE edition for quite some time and overall I’m quite happy with it.

There’s only one issue that bugs me every now and then. I’ve ONLY 4k resolution available on one of my external monitors.

To start off, my system configuration:

Dell Precision 7540 (Laptop)

  • KDE Plasma Version: 5.20.5
  • KDE Frameworks Version: 5.78.0
  • Qt Version: 5.15.2
  • Kernel Version: 5.10.7-3-MANJARO
  • OS Type: 64-bit
  • Processors: 16 × Intel® Core™ i9-9980HK CPU @ 2.40GHz
  • Memory: 125.6 GiB of RAM
  • Graphics Processor (IGPU): Mesa Intel® UHD Graphics 630
  • Graphics Processor (dGPU): AMD Radeon Pro WX3200
  • External monitor 1: Eizo Foris 2434 (FHD, fine)
  • External monitor 2: Acer XB280HK (UHD, the one in question)
  • Both external monitors are connected through an WD19TB Thunderbolt 3 docking station (which works pretty nice as a side note). PS: Already tested it, that’s not the issue; see below.

$ xrandr
Screen 0: minimum 8 x 8, current 7679 x 2160, maximum 32767 x 32767
eDP1 connected 1920x1080+5759+1080 (normal left inverted right x axis y axis) 340mm x 190mm
1920x1080 59.98 + 59.93 47.98*
1680x1050 59.88
1400x1050 59.98
1600x900 60.00 59.95 59.82
1280x1024 60.02
1400x900 59.96 59.88
1280x960 60.00
1368x768 60.00 59.88 59.85
1280x800 59.81 59.91
1280x720 59.86 60.00 59.74
1024x768 60.00
1024x576 60.00 59.90 59.82
960x540 60.00 59.63 59.82
800x600 60.32 56.25
864x486 60.00 59.92 59.57
640x480 59.94
720x405 59.51 60.00 58.99
640x360 59.84 59.32 60.00
DP1 disconnected (normal left inverted right x axis y axis)
DP1-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 620mm x 340mm
3840x2160 60.00*+ 24.00
DP1-2 disconnected (normal left inverted right x axis y axis)
DP1-3 connected 1920x1080+3840+1080 (normal left inverted right x axis y axis) 530mm x 300mm
1920x1080 60.00*+ 50.00 59.94
1680x1050 59.88
1600x900 60.00
1280x1024 60.02
1280x720 60.00 50.00 59.94
1024x768 60.00
800x600 60.32
720x576 50.00
720x480 60.00 59.94
640x480 60.00 59.94
720x400 70.08
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
DisplayPort-1-3 disconnected (normal left inverted right x axis y axis)
DisplayPort-1-4 disconnected (normal left inverted right x axis y axis)
DisplayPort-1-5 disconnected (normal left inverted right x axis y axis)
HDMI-A-1-2 disconnected (normal left inverted right x axis y axis)

Things to note:

  • DP1-1 is the UHD monitor.
  • DP1-3 is the FHD monitor
  • eDP is the internal laptop screen (which is normally deactivated, just not here)

What I’ve tested so far:

  • Adding FHD resolution as a custom one to xrandr. Adding was not an issue but got a black screen once switching.
  • As I’ve a dualboot with Windows 10, I checked there. No issue there, I can select lower resolutions just as expected.
  • I tried using the mDP port of my Dell directly but no change there either. My Acer monitor unfortunately has only one DP port, so no HDMI to try out.

Someone else has more ideas what could be wrong here?

Greetings