'One or more files did not pass the validity check' when trying to install "Fade In" & can't open "Scrivener"

Hi everyone! Total newbie here so pls forgive me if this is a stupid question.

I discovered the software I wanted to install in the AUR repo. I tried to install it and I got this error:

Building fadein…
==> Making package: fadein 3.0.634-1 (Thu 17 Dec 2020 09:11:49 GMT)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
→ Found fadein-linux-amd64-demo.tar.gz
==> Validating source files with md5sums…
fadein-linux-amd64-demo.tar.gz … FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build fadein

Can anyone guide me please? Thanks!

** Also I added a program called Scrivener through AUR - it successfully installed but when i try and open it - nothing happens :frowning: No error message .

1 Like

sudo rm /opt/scrivener/lib/libfreetype.so.6
This command to get Scrivener working.

Concerning Fadein. The latest tarball has a higher version in it then in the PKGBUILD. This also means the build still breaks if you disable integrity checks, because the folder name is different. Marked as out of date.

You can find this sort of info in the comments of the AUR package here and here

1 Like

Thank you so much Chomsky! Scrivener is now working.

So I don’t really understand the explanation for why Fade In doesn’t work. Do I just wait until someone updates it? Or is there something I can do?

Cheers!

It is up to the maintainer to update the package, the last update was in April this year.

You could try building it with pamac build fadein and edit the build file and change pkgver=3.0.634 to pkgver=3.0.640

and also change
md5sums=(‘b96e4fcfe84f484ab0fc949a7720b6c7’)
to
md5sums=(‘3a13fa16386ec0749c65e057167998e8’)

The downloadlink points to that version so give it a shot.

1 Like

Sorry to be a pain but what exactly would I type into the terminal?

Dont bother, I tried it but didnt work out :disappointed:

1 Like

Nevermind bro! Thanks for helping me with Scrivener. I’ll have to figure something else out with Fade In!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.