One of my monitor screens is blinking every second or so after system update

I’ve got two monitors, an Acer and a LG. I did a full system update with sudo pacman -Syu earlier today, and after reboot, my LG monitor is going black every second or so (not a full power off, just the screen as if it’s having trouble rendering). My Acer monitor is perfectly fine, and both monitors were working pre-update.

Edit: I’m noticing that it seems to blink less often if there’s no mouse or keyboard input. It will blink for some time after keyboard input has stopped, but will eventually calm down?

Edit 2: Changing the resolution to something else besides 2560x1440 seems to have stabilized the LG monitor. Changing it back to 2560x1440 causes the blinking to happen again.

Edit 3: I’ve disabled the Adaptive-Sync option in my LG monitor’s settings menu (GSYNC-compatible FreeSync) and the blinking has gone away. Seems like something in the update broke compatibility with it. While I can make do with this disabled for now, it’s not ideal. Is this a known issue with FreeSync and is there a fix for it?

Any help is appreciated.

I’ve tried:

  • Changing the refresh rate of the LG monitor from 144Hz to 60Hz, but no dice
  • Upgraded kernels from 5.4.231-1 to 6.1.12-1, but it’s still happening

Any help would be appreciated because this is a very annoying issue. Thanks.

    Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.5 Distro: Manjaro Linux
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 1405
    date: 11/19/2019
  Info: 8-core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 2524 min/max: 2200/4426 cores: 1: 4069 2: 2200 3: 2118
    4: 2200 5: 2167 6: 3366 7: 2107 8: 2100 9: 2725 10: 2136 11: 2084 12: 2261
    13: 2200 14: 4313 15: 2178 16: 2171
  Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] driver: nvidia v: 525.89.02
  Device-2: Focusrite-Novation Scarlett 2i2 Camera type: USB
    driver: snd-usb-audio
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: nvidia gpu: nvidia
    resolution: 1: 2560x1440 2: 2560x1440~144Hz
  API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce RTX 2070
  Device-1: NVIDIA TU104 HD Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Focusrite-Novation Scarlett 2i2 Camera type: USB
    driver: snd-usb-audio
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi
  IF: wlp4s0 state: up mac: 24:ee:9a:22:37:bf
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp5s0 state: down mac: 04:d9:f5:82:70:79
$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!

Check Wayland if it works?

Switch the monitors around? I.e. plug Acer into LG’s current port and vice versa.

1 Like

Just tried this. Turned Adaptive-Sync back on, then swapped the DisplayPort ports of the two monitors at the graphics card. LG was still blinking even when swapped.

I have the same issue in manjaro testing running the linux61-nvidia 525.89.02 driver with an RTX 2070, external displayport monitors appear to renegotiate the link frequently causing the monitor to shortly go black and reappear (also sometimes I have the monitor showing the input source as if reconnecting the monitor). Downgrading to 525.85.05 appears to fix things for now.

I think that did it, thank you so much!

Yes, that seems like exactly the same symptoms I had for my monitor.

I downgraded to the video-nvidia-470xx driver and turned Adaptive-Sync back on… so far so good. I don’t have a need to have the absolute latest Nvidia drivers, so these are probably good enough until the next update.

What I did (for future reference):

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx

I used the downgrade command to fix the linux61-nvidia and nvidia-utils packages to 525.85.05, however, because of dependencies I had to downgrade linux61 and linux61-headers packages to 6.1.9 as well, so it appears my kernel will be stuck until this is resolved by nvidia.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.