Onboard keyboard crashing after update

A few days ago I updated my manjaro through pamac but I didn’t restart the system until today. When I restarted it I was confronted with several nasty issues.

First I noticed that the onboard virtual keyboard crashes a few seconds after you hover the arrow pointer over it. I configured the onboard keyboard to appear on the login screen but I was unable to use it today because it crashed as soon as I started typing on it. So today I had to type my manjaro password by using the regular keyboard.

I also noticed that pamac doesn’t display the Aur packages anymore, although aur is enabled in the settings. I searched for this issue on this forum and found this thread

which advises to turn off the software mode, but this setting is already turned off my settings for pamac.

Any idea how to make the onboard keyboard function normally again and how to fix the Aur not working in pamac?

AUR is Arch User Repository - no support offered - what-so-ever - you are required to manage on your own.

Onboard keyboard assume some kind of touch support - flaky at best.

Any kind of assistance requires removal of any and all custom scripts as any of those may interfere with a repo sync

It seems that pamac was stuck on updating Google Chrome from aur, and when I pushed it to finish that update it now displays the Aur packages again. So at least that issue seems to have been resolved.

Could you please elaborate on the removal of custom scripts? I don’t know what that means. I didn’t make any custom scripts for the onboard keyboard. I simply installed it from the official repository when I first installed this manjaro about a month ago, and it worked normally until the latest update.

A few days ago when I updated the whole system, and after today’s restart, this onboard keyboard doesn’t work anymore. It just crashes as soon as you try to type something on it. Is there a way to install a previous version of this software?

Custom scripts is used to create a package outside the official repo such as using AUR [Need-To-Know] About Manjaro and AUR.

The packages listed by the following command is considered custom - that is per definition - any package not in the official repo (that may include obsolete manjaro packages)

pacman -Qqm

This is what I get when I type that command

$ pacman -Qqm
eddie-ui
google-chrome
gtkhash
gtkhash-thunar
khtml
kjs
python-manjaro-sdk
qtvkbd
spectre-meltdown-checker
web-installer-url-handler
xnviewmp

I recognise some of these packages as softwares that I installed ( for example, xnviewmp,qtvkbd, eddie-ui, google-chrome, gtkhash), but I don’t recall installing the other ones on this list. Does anything here look like something that could interfere negatively with onboard keyboard?

Remove them - rebuild the ones you deem necessary.

sudo pacman -Rns $(pacman -Qqm)

Then update your system

sudo pacman Syu

Reboot and see where you are …

Why not start with the most obvious choice?

There’s a qt6-virtualkeyboard package I’ve seen lately. Is that perhaps a replacement for qtvkbd?.. any thoughts on that?

Yes I installed that package today in an attempt to replace the onboard keyboard, but it didn’t work. It doesn’t show up in the start menu at all.

Most of them don’t; they are meant to be instead configured in settings. There’s Maliit keyboard that is supposed to be a favourite lately. See what you can find out about that.

Whatever you try, though, you’d best remove anything that might conflict with it; like, all other keyboard packages you’ve tried to install. I’d probably remove qtvkbd to start with.

Okay, so I did as you suggested, and removed all those packages, updated the system and restarted it. Unfortunately, onboard keyboard still crashes as soon as the arrow pointer hovers over it. By “crashes” I mean it just disappears from the screen, as if it was exited.

This is the error that I see if I run that program from terminal

$ onboard
Segmentation fault (core dumped)

Does this “segmentation fault” tell us anything more about the reason why it crashes?

Damaged file; incompatibility with something; or perhaps a bug. Difficult to say. You could try an Internet search for the exact error to see if that reveals anything.

Is Onboard installed from the AUR?
It’s available in the official Manjaro repo’s; that’s the preferred source.

Onboard keyboard was installed from the official repository, not from Aur.

Well, it appears that I am not the only one with this issue. Please take a look at this thread:

https://bbs.archlinux.org/viewtopic.php?id=150856

The solution is in downgrading a certain Python package, but I don’t know how to do that. Can anybody explain how to downgrade that Python package as explained in the above mentioned forum thread?

That’s a 14-year-old post; it might not be a reliable reference in 2024…

I mentioned Maliit keyboard earlier, which apparently works well with Plasma. You might (or might not) need to remove Onboard first. You would install Maliit with:

sudo pacman -S maliit-keyboard

With most virtual keyboards, once it’s installed, you would normally go to:
Input DevicesVirtual Keyboard(Name of Keyboard) and configure it there. In this case it would be named Maliit.

It might be worth looking at instead of Onboard, especially as it’s giving you so much grief currently.

It is true that that post is rather old, but since this issue started to happen after the complete system update, it seems plausible that some upgraded package like python happens to be incompatible with it and is causing the problem.

As for maliit keyboard, I use xfce manjaro not plasma. I installed Malit keyboard, but I don’t know where to find its settings. There is no section “input devices” In xfce settings

Also. I chose onboard because it can be configured to appear on the login screen of xfce manjaro as explained in this forum thread.

Can this Maliit keyboard also be configured to appear on the login screen?,

This thread is currently in a category for KDE. Perhaps you’d like to adjust that accordingly, to avoid confusion. In fact, nevermind, I’ll do it for you.

I’ve never used it. However, it looks like many others have:

I have managed to get onboard working by changing “Input event source” to GTK

1 Like

That did it for me as well, thanks!

@Antarmanu71 Next time, one subject per topic please. I’ve edited your topic title to reflect the overall issue that also has a related solution.

In the future update repo packages first, then worry about AUR packages later.

If you need help with AUR packages, feel free to post in our AUR section.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.