On network issues

Let me ask; how are you connecting to Internet usually? Is it via a WiFi capable Modem/Router connected to your ISP? If you have a network cable you could physically connect to the router in the meantime.

Now, with the capitalization issue solved, here is the difficulty which might be preventing much progress: It is possible; and likely; that running an instance of dhcpcd.service is conflicting with NetworkManager.service – as @megavolt has already indicated – as both should not be active at the same time under normal circumstances. However, NetworkManager.service does appear to be operating as expected.

A few questions that might help:

  • Are you using a firewall that might be blocking connection? If so, disable it temporarily, reboot if needed, and test again.
  • Which kernel was the ax201 working with previously?
  • Have you tried reverting to that kernel to see if it still works? If not, try it, and report back with the results.
    Have you tried the latest 6.6.7-1 kernel? If not, try it, and report back with the results.
  • And finally; Never having problems with the ax201 in Manjaro doesn’t mean you never will. It’s possible that it’s taking an early retirement. Can you test the card with another OS, or another computer?

ok, I connect through my phone hotspot. I don’t have a modem or internet at home. I have had the same PC with manjaro, phone and provider for last few years, all was very stable.

It started with last upgrade, I’m using 6.6.7-1, before 6.1.68-1. I try to stick with LTS as both are.

  • I disabled firewall, rebooted… no change

  • I reverted to 6.1, no change

  • as for the card, it’s working when I sudo systemctl restart dhcpcd (like right now)

It’s NetworkManager …when I go on the icon with mouse pointer, it says inactive and when I click wifi is on but no wireless connections show

OK. I’m unable to help with this scenario. I had assumed you were using your phone as a hotspot out of desperation, than much else.

At least now there’s a little more information that might help others.

Good luck.

Aside:- I found another active thread NetworkManager is not running, which might (or might not) be worth monitoring. Cheers.

1 Like

what does your iptables says:

systemctl status iptables

are else the full list:

systemctl list-unit-files|less 

sorry about the delay, never got a notification about your message

systemctl status iptables                                                                                                                          ✔ 

○ iptables.service - IPv4 Packet Filtering Framework
     Loaded: loaded (/usr/lib/systemd/system/iptables.service; disabled; preset: disabled)
     Active: inactive (dead)

UNIT FILE                                  STATE           PRESET
proc-sys-fs-binfmt_misc.automount          static          -
-.mount                                    generated       -
boot-efi.mount                             generated       -
dev-hugepages.mount                        static          -
dev-mqueue.mount                           static          -
proc-fs-nfsd.mount                         static          -
proc-sys-fs-binfmt_misc.mount              disabled        disabled
sys-fs-fuse-connections.mount              static          -
sys-kernel-config.mount                    static          -
sys-kernel-debug.mount                     static          -
sys-kernel-tracing.mount                   static          -
tmp.mount                                  generated       -
var-lib-machines.mount                     static          -
var-lib-nfs-rpc_pipefs.mount               static          -
var-lib-snapd-snap-core18-2566.mount       enabled         disabled
var-lib-snapd-snap-snapd-16778.mount       enabled         disabled
cups.path                                  enabled         disabled
gpm.path                                   static          -
ostree-finalize-staged.path                disabled        disabled
systemd-ask-password-console.path          static          -
systemd-ask-password-wall.path             static          -
session-2.scope                            transient       -
accounts-daemon.service                    disabled        disabled
acpid.service                              disabled        disabled
alsa-restore.service                       static          -
alsa-state.service                         static          -
apparmor.service                           disabled        disabled
archlinux-keyring-wkd-sync.service         static          -
auditd.service                             disabled        disabled
auth-rpcgss-module.service                 static          -
autovt@.service                            alias           -
avahi-daemon.service                       disabled        disabled
avahi-dnsconfd.service                     disabled        disabled
blk-availability.service                   disabled        disabled
bluetooth-mesh.service                     disabled        disabled
bluetooth.service                          enabled         disabled

Ya, I guess I’m out as well…

Check back with Official Update News about other Kernel Version [ Stable Update ]

Make sure you can get NetworkManager running through the Wiki config info

The output off systemctl list-unit-files|less should be around 540 lines, but with that you can see what’s running in the background and start / stop programs that mayd be in conflict with your Wireless.

To show the full list, this would work, then you are just have to post back the link:

systemctl list-unit-files  | curl -s --data-binary @- 'https://paste.c-net.org/'

My issues were Bluetooth, sometime Portmaster and iptables ones.

A GUI Software for that is pamac build stacer from the AUR

  1. Service
  2. only toggle the Running now column.
  3. not the Startup at boot section, only if you are sure that is really the problem, but maybe then still let us know first.

But all this is more a thinker option.

Otherwise, backup your stuffs, maybe it’s time to restore to a previous point. timeshift

I read your post during the night and didn’t understand a thing
this morning it was easier after coffee and clear mind, well not that I understood much))) but was able to get the info at this link


1 Like


sudo systemctl disable --now systemd-networkd.service
sudo systemctl enable --now NetworkManager
 sudo systemctl disable --now systemd-networkd.service                                                                                              ✔ 

[sudo] password for : 
    ~  sudo systemctl enable --now NetworkManager                                                                                                  ✔  6s  

    ~                                         

I entered the commands before reboot, no change; entered them again, still no change.
When I reboot I get the network notification saying that network is connected but limited, no wifi shows. Still to get connected must enable dhcpcd

I see, then I’m out.

Beside the Previews post, make sure the System is up-to-date, and your pacnew files are on point. pacnew

pacdiff -o

I asked this question earlier. Perhaps you thought you answered it. You didn’t. I’ll ask it again:

Which kernel was the ax201 working with previously?

Revert to that kernel (the kernel that was working before, whichever that was).

Does your Internet scenario still work the way you were expecting when using that kernel (the kernel that was working before, whichever that was)?

If it does, then, problem solved.

Two things I saw in your pasted output (first state is the current state, second state is the preset aka default)

systemd-networkd-wait-online.service enabled enabled

It is disabled on my system (which is not Arch, but that should not matter).

systemctl status systemd-networkd-wait-online.service
○ systemd-networkd-wait-online.service - Wait for Network to be Configured
     Loaded: loaded (/lib/systemd/system/systemd-networkd-wait-online.service; disabled; vendor preset: disabled)
     Active: inactive (dead)
       Docs: man:systemd-networkd-wait-online.service(8)

I’m not sure what the expected system response is when this service is active - what happens when the service detects that the system becomes online.

ufw.service enabled disabled

the firewall is active - what it does depends on the rules it has been configured to use

I’d switch back to the kernel where everything was working if I could.

did that too just now

thank you for pointing that out but I am pretty sure I answered that in details, guess you thought you didn’t read it))) it’s right there (2 days ago, don’t know how to put here)

anyways no troubles

update, yesterday upgraded to kernel 6.6.7-4

again (no disrespect) I tried going back to previous kernel 6.1.68-1, that was working before, not anymore
my system, connection, or anything else has not changed since I installed manjaro 2 years ago. everything was rock solid until I started this tread

If indeed literally nothing changed - except what was “changed” by the update
(and no one else was affected by it in this way)
then it is very much a mystery to me - and I have no suggestions on how to approach this.

thank you anyhow
tried also kernel 6.5, no change

the network icon is inactive (although at boot says connected but limited…but not connectes) , the wifi is on but no connection shows, only way to connect still dhcpcd…mystery alright and crazy

… sounds a bit like a (accidentally?) messed up NetworkManager configuration.

You likely did check that already.

(right click the icon - edit connections (or however it is in the english locale) and check every aspect in the six tabs available, especially the IPv4 and IPv6 options (of which you really only need one)

in my Manjaro VM
this service


is definitely NOT active

althoug it’s preset/default condition is “enabled”
it is “disabled” - but I did definitely not set it to “disabled”

Your’s is active - which is not the default …

I’m referring to what you pasted to


I hadn’t change anything in network manager, once the connection was configured, never went there

anyway, did it again just now, also disabling IPv6, no change
isn’t there a way to uninstall networkmanager, disable all conflicts, and reinstall networkmanager easily?
or go to some default scheme?

this disables that?
cause I try it everytime I boot

sudo systemctl disable --now systemd-networkd.service

All your created connections are in:

I’m not sure what you mean by:

especially the “conflicts” part

There should not be any “conflicts”.

Of course you can uninstall it - but nothing will have changed after installing it again.

default scheme: remove all your connections from:


this does not disable:


it is a different service - different name

the disabling only needs to be done once - it won’t magically re-enable itself

for conflicts, I mean at some point in the thread I was told to disable dhcpcd.service, iw.service etc, but if nothing changes the it was a thing not relevant to say by me (guess on possible on windows)