Okular not showing network printer

Hello all,

I have a weird problem I noticed in the past week on my machine running manjaro kde with the latest updates for programs and kernel:

I open a pdf in okular and want to print it and the only option is to print to file! I have a canon network printer that appears in the system printers sections and I can print to it with other programs (eg. Foxit pdf viewer for linux). I know I have used this printer with okular in the past and I have no idea when it stopped working because I don’t print that much.

Anyone has this problem? Or can anyone help me figure it out?



Can you please open up Okular from terminal, then open a file and try to print it. Let us know what error you get.

there is no error when I open from the command line. In fact there are no messages at all! I do: okular some-pdf-file.pdf and there is no message. Try to print and all I get is the print to file option. Then I close and still no message.

How about:

okular --print some-pdf-file.pdf  

I found this:

[okular] [Bug 456344] New: Driverless printers do not appear in the Qt print dialog

and 3 replies

Seems to mean that okular is not the problem, but something else in perhaps qt or somewhere else
… not very helpful, I know

aha! so the problem seems to be qt! cool. i’ll wait for an update then. or can I do something about it?

If that’s the case then you would face the same problem with Kate, Kwrite etc. Do you?

YES! same thing! I just noticed now that you said

Someone reported it already

1 Like

solved! the new updates (don’t know which one did it!) solved the issue! thank you!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.