Okular - blank pages (partial open) - all black

Hello everyone
I don´t seem to find a similar toppic or problem to this of mine.
Use okular for quite some while, but I have not encounter the following problem.

Some PDF files are not opened, only the first page. The rest (starting from No.2) appear kind of blank or they are not there at all.
If I open the same PDF file with any other reader (xPDF etc.), opens the files/pages without any problems.

I tried to uninstall and reinstall okular, using the terminal…but still having the same problem.
It only happens to some PDF files (example the one that I scan back in the office), but only for some.

I uploaded a screenshot.
Does anyone have an idea? Is a plugin issue or something?
I tried to “play” with the settings, but no luck.

I appreciate any help.

Does this file open properly in chrome or firefox?

Yes absolutely. I can view the file within my gmail account (preview) without any problems! If i uninstall all PDF viewers (tried that to), than the files opened by the browser is viewable in 100%.
As I mentioned, this is a scanned document. I never have the problem with direct PDF downloaded files from WWW, only the scanned ones (not all, just some).
And what I have noticed, after restart, the first time I open the file on my computer, okular opens and maybe for a 1/100 second I see all of it in the Thumbnails, but after that starting from page 2 suddenly goes everything black just like in the posted screenshot.

Kind of annoying and I don´t seem to find the solution and I don´t want to change okular, because I like it and its the best for Manjaro out there.

Open konsole. Launch okular via command in this window. Open in Okular PDF file. Paste in reply what will be in konsole.

Hi FadeMind

Followed your instructions and the problems still stays:
You will find the Terminal below.

[stefan@stefan-pc ~]$ okular
Icon theme "breeze" not found.
Icon theme "breeze" not found.
Icon theme "breeze" not found.
Icon theme "breeze" not found.
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1476, resource id: 10570191, major code: 40 (TranslateCoords), minor code: 0

Or see my Pastebin.
Hope this helps you see something. Only the hint of “error” doesn´t seem right to me.

I appreciate it in advance.

Install breeze-icons to get rid of those messages (that’s definitely isn’t connected with your issue, but fewer warnings is always better :wink:):

I don’t know what is last message, but sound for me like OpenGL issue, show:

glxinfo -B

Probably more useful logs will show when you open problematic pdf:

okular problematic.pdf

qt.qpa.xcb error is upstream qt libs issue. > [QTBUG-87141] QDialog causes the warning: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 706, resource id: 18344964, major code: 40 (TranslateCoords), minor code: 0 - Qt Bug Tracker Ignore this.
blank pages
IMHO it is similar issue here 437246 – Okular does not render parts of PDF document (kde.org)

HI Tomek

You are right. Breeze was missing. I took care of that.
I pasted the information of the glxinfo here:
When i tried to open the problematic.pdf file, unfortunately there was no such documents on my home folder.

Yes. Seems to be a rendering problem, but with no solution.
Ok :smirk: :slightly_frowning_face:. So that means I have to live with it.
Thank you anyway for trying. I appreciate it.