Oh no! white screen in Manjaro Gnome after updgrade (can't access other tty)


I performed the last update using pamac and after reboot, I’m getting the “Oh no!” white screen, which weirdly is asking for my keyring password.
Even if I insert the password the screen changes and ask me to contact my sys admin.

I’ve tried accessing another tty but I just get a black screen (from F3 to F12).

Any ideas on how I can recover my system?

I’m downloading a Manjaro Gnome iso right now.
If I chroot into my installation, what should I try?


This usually indicates a partial-upgrade.

Please see this:

Then do your fixing.
Maybe start with a mirror sort and update, just to be sure:

sudo pacman-mirrors -f && sudo pacman -Syyu

I had this exact error. In my case It appeared that GDM expects a differenct cursor after the update and it was not installed. After I did pacman -S xcursor-breeze, GDM would start again. I was lucky however that my TTY 's still worked with Ctrl-ALT-F?

So, I was able to chroot and installing the xcursor-breeze solved it for me too! Maybe the Manjaro Team should add it to the “Known issues and solutions” in the update post.

For future reference, what I did was:

  1. Boot from Manjaro USB stick
  2. Open a terminal
  3. su
  4. manjaro-chroot -a
  5. Even though the system appears as “0”, insert “1” as option (otherwise it doesn’t work)
  6. sudo pacman-mirrors -f && sudo pacman -Syyu
  7. pacman -S xcursos-breeze
  8. Reboot.

I tried reinstalling gdm and gnome-shell before it, but it did not work.

Thanks for your help.

Hi, I’ve just registered and reply to this thread to indicate that installing the cursor did indeed solved my issue too.

I’ve tried to update GPU drivers, disabling gnome shell extensions and other methods, but it’s only installing that particular cursor that had solved the issue for me. Thanks heaps for sharing the solution!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.