Oh dear: "Under-voltage detected! (0x00050005)" --> Need advice

So, after plugging in a wall-powered USB 3 BluRay drive, I immediately ran into some issues…

The Pi immediately crashed, but that could have been from me jiggling the power cord while I was moving it around. That’s happened before.

On restart, I noticed it took a few tries to start up; it would attempt to start, reboot, wait a few seconds, reboot, etc…

That didn’t seem right, so I checked dmesg.

[Mon Aug 30 17:34:27 2021] Under-voltage detected! (0x00050005)
[Mon Aug 30 17:34:31 2021] Voltage normalised (0x00000000)
[Mon Aug 30 17:34:45 2021] Under-voltage detected! (0x00050005)
[Mon Aug 30 17:34:49 2021] Voltage normalised (0x00000000)
[Mon Aug 30 17:37:37 2021] rpi_firmware_get_throttled: 1 callbacks suppressed
[Mon Aug 30 17:37:37 2021] Under-voltage detected! (0x00050005)
[Mon Aug 30 17:37:47 2021] Under-voltage detected! (0x00050005)
[Mon Aug 30 17:37:51 2021] rpi_firmware_get_throttled: 2 callbacks suppressed
[Mon Aug 30 17:37:51 2021] Voltage normalised (0x00000000)
[Mon Aug 30 17:37:53 2021] Under-voltage detected! (0x00050005)
[Mon Aug 30 17:38:13 2021] Voltage normalised (0x00000000)

I’m overclocked, with overvoltage set to 6. Up until I plugged in the BluRay, this wasn’t an issue.

over_voltage=6                                                                # Overvolt CPU
arm_freq_min=1000                                                             # Keep CPU from dropping below 1 Ghz
arm_freq=2000                                                                 # Max speed @ 2.1 GHz    

A couple of questions:

  1. Will increasing the overvoltage to 7 or 8 actually help this? Or…
  2. Is this an indicator the PSU I’m using is not up to the task?
  3. If the external drive is powered from the wall, why does the Pi end up getting hit with an undervoltage event?

no, that’s different.
it’s the power supply itself, the blueray probably draws to much power. you need to keep in mind the usb’s are shared, so other usb’s you have plugged in are also drawing power.

i use a hub on mine & upgraded my rpi power to a 3.5w version, instead of the standard 2.5.

you don’t need over_voltage= any more, recent kernels handles that on the fly.
arm_freq_min= also has no effect in recent kernels, you’ll find it usually doesn’t go lower than 1.3ghz in manjaro.

I have 3.5A PS and I can have the same. Mouse, 100 mA, backlit keyboard 500 mA, low power USB SSD 400 mA and the next item is probably 200 mA or more and that is max.

I have a powered USB 3.0 hub, and even though it is powered, it draws power. If I plug it in, I can get the exact same warning message… even if I move both the mouse and keyboard to the powered hub. So just the SSD and powered hub are plugged in the two USB 3 ports, and I can get the message. I can not say exactly why, seems it should not be the case… but it is.

And with the power, mouse and keyboard plugged in that hub, the rpi4 won’t boot. Unplug the power and it does boot.

If I use a different powered USB 3 hub, it boots fine with power, but the mouse must be unpluged and re-pluged to work, but it works fine on other hub.

I can not explain any of the above. My advise… try some other arrangement, maybe something will work for you. But I doubt it is the power supply or your overclocking. Yes, overclocking pulls more power… but I bet USB is the issue.

1 Like


As much as I love the Pi, I’ve been consistently disappointed with the USB subsystem. It’s entirely too finicky. (You may recall my previous adventures with a 2.5Gbps ethernet adapter. I felt so bad about that, like I made @Darksky do a bunch of hacking for nothing.)

At the same time, it’s hard to beat the 9W power consumption for home server use. :stuck_out_tongue:

I solved this problem–when I plugged the DVD burner in, I jostled the crappy power brick that came with the DeskPi case (it’s pretty much the shape of one of those small iPhone chargers that come in the box). It was out of line just enough to undervolt even without the DVD burner plugged in. I cleaned up the arrangement, and it’s fine.

I am le tired, so I haven’t tried turning the DVD drive back on yet. :stuck_out_tongue: Tomorrow.

Tomorrow, I’ll take a closer look at the silk-screening on the back of the DeskPi PSU to see exactly what it’ rated for, and compare that to the Canakit 3.5A version, as well as a spare Apple iPhone charger I have.

In the meantime, @kerry_s, I’m intrigued by your remarks re: the config.txt directives.

Which kernel handles overvolting without explicit commands? I can’t find it via search. I’d love to have a cleaner config.txt.

Re: Minimum Clock Setting. The 5.10.x and 5.12.17 kernels seem to recognize it, whether or not it has any impact.

Here’s the 5.13.x kernel, on an older 4GB Pi:

~]$ lscpu
Architecture:            aarch64
  CPU op-mode(s):        32-bit, 64-bit
  Byte Order:            Little Endian
CPU(s):                  4
  On-line CPU(s) list:   0-3
Vendor ID:               ARM
  Model name:            Cortex-A72
    Model:               3
    Thread(s) per core:  1
    Core(s) per cluster: 4
    Socket(s):           -
    Cluster(s):          1
    Stepping:            r0p3
    CPU max MHz:         2000.0000
    CPU min MHz:         1000.0000
    BogoMIPS:            108.00
    Flags:               fp asimd evtstrm crc32 cpuid
  Itlb multihit:         Not affected
  L1tf:                  Not affected
  Mds:                   Not affected
  Meltdown:              Not affected
  Spec store bypass:     Vulnerable
  Spectre v1:            Mitigation; __user pointer sanitization
  Spectre v2:            Vulnerable
  Srbds:                 Not affected
  Tsx async abort:       Not affected

it was talked about on the raspberry forums. i tested the settings on a manjaro xfce install.
i’m currently using raspberry os 64bit with the arm_freq=2000 only.

1 Like

The pi is not a desktop computer - it is limited when it comes to powersupply over USB.

Always power power hungry peripherals from an external source - that means use an USB hub which is externally powered.

The Pi is very vulnerable when it comes to power


Thanks, @kerry_s !

@linux-aarhus , that’s what threw me. The DVD drive I’m using is powered by a massive external power supply. I had assumed I’d be fine. I do have a powered USB 3 hub, but my older Raspberry Pi 4b 4GB was extermely crashy with it.

As noted above, part of my issue was poor connectivity into the power strip. I haven’t retested since then. I need to. :slight_smile: