Odd behavior of Veracrypt in Manjaro KDE Plasma

Hi, all. I have been experiencing a problem running Veracrypt from the Manjaro KDE Plasma command line. I posted a question regarding this issue in the Veracrypt forum, and received a response claiming this problem is not related to Veracrypt, but to KDE Plasma instead. I am not sure that’s right, but I am hoping someone here can shed some light one way or another. Below, I have inserted my original post in the Veracrypt frum and the response I received:

My posted question:

I run Veracrypt 1.24-Update7 on Manjaro KDE Plasma. I mount my Veracrypt volumes from the command line, and when doing so, while the volume in question mounts OK, I also always get the following error message (see below). Even though it says that style property is deprecated and will be removed in a future version, I have been getting this message for as long as I can remember, which each new version of Veracrypt and nothing ever changes. Is there anything I can do to stop this error message from appearing? Thanks

(veracrypt:4501): Gtk-WARNING : Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn’t be used anymore. It will be removed in a future version

Response I received:

Without any deep and further knowledge about GNOME and its mechanics, I would assume that you should upgrade your system theme to a version that does not utilize deprecated functionality. I don’t see how this would related to VeraCrypt.

Just to be sure, I’ve crawled both the source code of VC 1.24u7 as well as my whole drive. There is no gtk.css related to VeraCrypt to be found.


I think this is something related to your KDE theme or settings. I also use Veracrypt on KDE and I don’t have any errors

What theme are you using, maybe Adwaita?
Have you installed your theme from AUR?
Is your system fully updated, incl. non-native (AUR) packages?

I use the default Breeze theme, have never changed any of the defaults, and have not installed any theme from AUR. My system is fully updated, I check for updates every morning.

I would just try other themes to see if the warning disappears.

Thanks, Wollie, I may just do that.

Don’t forget, it’s just a warning. If you open via desktop icon it won’t appear. :wink:

Correct, this only appears when I launch it from the command line, and, in addition, it does not appear to have any impact on functionality at all. It’s just, I would rather not have this “warning”, especially when there does not appear to be a cogent explanation for it. Thanks a lot.

I found these warnings to be more common than one would expect. I, too, get the same warnings (when launched via the terminal) on a handful of applications, including the latest version of VeraCrypt. As long as it doesn’t affect the use of the application. :slight_smile:

Though you may find this warning annoying, it servers a purpose.

When(not if) that theme will get updated (and it will, it’s the default kde theme) - this warning will disappear.

If you want to open veracrypt volumes from the command line and not see warnings regarding graphical user interfaces, try using cryptsetup:

$ sudo cryptsetup open /path/to/veracrypt-container.hc --type tcrypt --veracrypt veracryptcontainer
$ sudo mount /dev/mapper/veracryptcontainer /mnt

I think you are mistaken. The warning mentions the file gtk.css and Breeze theme doesn’t include that file, but Breath theme does. And even more, the line 73 of that file (/usr/share/themes/Breath/gtk-3.0/gtk.css) is:

 -GtkScrolledWindow-scrollbars-within-bevel: 0;

that is the property and the line number the warning is talking about.

So check your theme settings again to make sure what theme are you using.

I stand corrected. A few months ago I switched from Breeze to Breeze Dark, had been using Breeze for years. Prior to switching, I was getting a very similar error message from Veracrypt, though. So, my settings are:
Application Style: Breeze
Plasma Style: Breeze Dark
Colors: Breeze Light
Windows Decorations: Breeze
Icons: Breeze
Cursors: Breeze
Splash Screen: Breeze

As you can see, I do not stray far, if at all, from Breeze.

You have to check what theme is being applied to GTK apps.

Confirm that you have kde-gtk-config installed and in KDE settings go to System Settings > Application Style > Configure GNOME/GTK Application Style and check there what theme is being applied to gtk apps. You may have to install breeze-gtk to use breeze for them too.

1 Like

kde-gtk-config was not installed, I installed it, then selected Breeze as the style for gtk applications and voila! problem solved!!
Thanks a bunch, cfinnberg.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.