Octopi stopped to connect to internet

Hi All,
I just installed Manajro KDE, everything was fine.
I installed, Octopi, and started to install few packages from there.
It started well, but I got some missing packages (sorry, I forgot to records the errors)
I ran a full update pacman -Syyu
and since then, Octopi cant connect, message: ‘it seems Internet is not available’
Pacman is working well.
I do not know how troubleshoot or repair it.
Can somebody give me some tips to settle this ?
Thanks in advance,

Try to remove the config file by

sudo rm $HOME/.config/octopi/octopi.conf

and reboot.

Hi and sorry for my late feedback
it still does not work, I tried to delete the conf file, desintall/reintall, re-delete the .conf, reboot, etc…
still the same error

Octopi has not been updated/rebuilt since October even though a new version came out in January, so some underlying library has probably updated, making Octopi fail.

I use Octopi only as a package browser in testing branch on KDE Plasma and so far I have not encountered any problem. Updates are done only via pacman, though.

Hi All,
can it be related to pkgfile ?

I had an error on boot: “failed to start pkgfile database update”
and I found this thread:
[FAILED] failed to start pkgfile database update

Indeed, pactree shows Octopi uses pkgfile

can it be related ?
(I settled the boot error by removing all zsh components)

octopi works well on my side, connection problems may not be related with pkgfile but you may try to disable the systemd service and timer

Tip: pacman has a similar functionality built in.

pkgfile ships with a systemd service and timer for automatically synchronizing the pkgfile database. To activate automatic updates enable pkgfile-update.timer

see here

Hi, Thanks for the tip, I disabled the timer
Octopi still does not connect to Internet

I guess I will have to wait the next version ! :frowning:

Hi all,
I just ran a full system upgrade and updated to Linux 5.11.18-1
Launch Octopi and checked for updates
Finally, I got an error message !!!
“ERROR: Cannot find the fakeroot binary. No updates available”
I installed fakeroot and it seems working fine !
Thanks all for you support and help on this matter.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.