Occasional screen "tearing"/glitching on new install

I’ve just downloaded Manjaro for the first time having just moved over from Ubuntu. I’m liking it so far but am encountering a problem, that despite searching and trying multiple answers from the forum I cannot seem to debug.

I’m currently facing an issue when every 2-3 minutes, or when doing certain actions like scrolling in windows or swapping between them, the screen will tear (not exactly tearing but it’s the closest approximation I have). It’s slightly static-like also, however only in a horizontal section of the screen and never across the whole screen.

I had a very similar problem when I first installed Ubuntu 21.04, which was fixed upon switching to the LTS version. I’ve tried the same thing with Manjaro however the problem persists.

For hardware, I am running an i7-8700K CPU, and an AMD Radeon R9 390 GPU.

I have tried both proprietary and open-source drivers, neither of which fixes the issue. I have created a file as /etc/X11/xorg.conf.d/20-intel.conf, and tried adding:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “uxa”
Option “TearFree” “true”

That only proceeded to blackout my screens on boot, requiring a fresh OS install.

Any help is much appreciated.

1 Like

If you haven’t messed with the compositor, try this.

Rename 20-intel.conf>20-intel.conf.bak


On your desktop, just start typing “compositor” and krunner should take you to the compositor settings. If not, use the search within the system settings menu.

Try different compositors and or vsync settings.

Something will probably work. I haven’t tried it on AMD though.

Are you sure these quote characters are good? To me they are not good.

"xxx" <- good
“xxx” <- no good to me

Anyway, you give an Intel config file for your AMD video?

First things first: How to provide good information

The quotations are just a forum issue. The config file uses the correct quotation marks.

My inxi output is as below.

  Kernel: 5.13.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=6c948301-3f5d-4f94-a53c-5bdbb40abfaa rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Gigabyte product: Z370P D3 v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z370P D3-CF v: x.x serial: <filter> 
  UEFI-[Legacy]: American Megatrends v: F5 date: 07/05/2018 
  Message: No system battery data found. Is one present? 
  RAM: total: 15.58 GiB used: 3.73 GiB (23.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 12 MiB bogomips: 88824 
  Speed: 4493 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 4493 2: 4499 
  3: 4389 4: 4441 5: 4483 6: 4501 7: 4423 8: 4481 9: 4432 10: 4488 11: 4479 
  12: 4473 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
  flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: AMD Hawaii PRO [Radeon R9 290/390] vendor: Gigabyte driver: radeon 
  v: kernel alternate: amdgpu bus-ID: 08:00.0 chip-ID: 1002:67b1 
  class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") 
  s-diag: 1055mm (41.5") 
  Monitor-1: DisplayPort-2 res: 1920x1080 hz: 60 dpi: 96 
  size: 509x286mm (20.0x11.3") diag: 584mm (23") 
  Monitor-2: DVI-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") 
  diag: 547mm (21.5") 
  OpenGL: renderer: AMD HAWAII (DRM 2.50.0 5.13.11-1-MANJARO LLVM 12.0.1) 
  v: 4.5 Mesa 21.1.6 direct render: Yes 
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0 
  class-ID: 0403 
  Device-2: AMD Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X] 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 08:00.1 
  chip-ID: 1002:aac8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.11-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: e000 bus-ID: 06:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 2.4 TiB used: 12.09 GiB (0.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-60WN4A0 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 2B6Q scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST1000DM003-1SB10C 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT 
  ID-4: /dev/sdd maj-min: 8:48 vendor: SanDisk model: SDSSDA120G 
  size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 00RL scheme: GPT 
  ID-5: /dev/sde maj-min: 8:64 type: USB vendor: SanDisk model: Cruzer Edge 
  size: 14.91 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 2.01 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 465.76 GiB size: 457.38 GiB (98.20%) 
  used: 12.09 GiB (2.6%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A 
  uuid: 6c948301-3f5d-4f94-a53c-5bdbb40abfaa 
  Alert: No swap data was found. 
  ID-1: /dev/sda1 maj-min: 8:1 size: 931.51 GiB fs: btrfs label: alpha 
  uuid: 163667f8-d8fb-4464-9f67-dae7114c6010 
  ID-2: /dev/sdc1 maj-min: 8:33 size: 931.51 GiB fs: btrfs label: charlie 
  uuid: 9decb31d-b64d-465d-a478-564291372257 
  ID-3: /dev/sdd1 maj-min: 8:49 size: 111.79 GiB fs: btrfs label: delta 
  uuid: 7d22f00e-07e9-4adb-96e0-3cc9bd103635 
  ID-4: /dev/sde1 maj-min: 8:65 size: 2.97 GiB fs: iso9660 
  ID-5: /dev/sde2 maj-min: 8:66 size: 4 MiB fs: vfat label: MISO_EFI 
  uuid: 97EE-3EF6 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:3 info: SanDisk Cruzer Edge type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA 
  chip-ID: 0781:556b class-ID: 0806 serial: <filter> 
  Hub-2: 1-8:28 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 1a40:0101 class-ID: 0900 
  Device-1: 1-8.2:29 info: ZSA Moonlander Mark I type: Keyboard,Mouse,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 2.1 speed: 12 Mb/s 
  power: 500mA chip-ID: 3297:1969 class-ID: 0300 
  Device-2: 1-8.3:30 info: Logitech G402 Gaming Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 300mA chip-ID: 046d:c07e class-ID: 0300 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 27.8 C mobo: 16.8 C gpu: radeon temp: 61.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 292 Uptime: 22h 7m wakeups: 0 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1302 
  lib: 345 flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.8 
  running-in: konsole inxi: 3.3.06 

Unfortunately, changing the vsync settings have not changed anything it seems, nor the config file suggestions.

I now have a video of the exact visual bug I’ve been dealing with. I haven’t been able to replicate it until now. For some reason, hovering over different games in my Steam library triggers the flickering effect.

Unfortunately, I can’t share the exact link to this video due to forum privileges. If to go to imgur and end the domain with /rzlGaDZ it should take you to it.

Still haven’t managed to find a fix for this. Again, go to imgur . com / rzlGaDZnsns you can see the screen tearing issue in question.

No solution found yet - bumping for visibility.

You have an AMD GPU so why don’t you try the same thing you did but for the amdgpu driver?


//EDIT: Also maybe try to force the use of the amdgpu driver (by using the package amdgpu-experimental or by using the same kind of modification this package does), if it can be compatible (maybe try directly or search).

1 Like

I noticed the same thing. Is there a reason you’re defining options for an Intel GPU, when in fact you have an AMD GPU?

Isn’t that card from 2013? (I don’t think it’s supported by the AMDGPU driver, but I could be mistaken.)

Perhaps try using “fresh” (i.e, none) xorg configs, and trying to disable/enable composting, and/or changing the latency options under KDE’s settings?

Here are a few options you can play with to see if it makes any difference:

UPDATE: It appears the card is supported by the AMDGPU driver, but considered “unreliable”. So if you want to try with the newer driver, as @omano alluded, you’d have to force it to ignore “radeon” and use “amdgpu”.

Thanks for the advice. Unfortunately, it’s resulting in the same issue as before; black screen on startup. I have to use the text console on boot and delete the file again to get the system to start normally.

I’ve tried all the settings in the compositor with no success sadly, and yes as far as I know the R9 390 should be a supported card still, although potentially unstable as you mention.

Still no solution as of yet. I’ve attempted various Xorg configs and none have worked (all result in a black screen on boot). Can’t seem to nail this issue down.

I’ve attempted running a few games to see if that exacerbates the issue and it indeed does, however is seems specific to the monitor I’m running the application on.

Bumping thread.

You can see if this helps:

Add the following option in your .conf file to also enable triple buffering,

Option "TripleBuffer" "true"

Don’t copy + paste this! Write it in manually to make sure you don’t insert incorrect ASCII characters.

Save, then reboot, and cross your fingers. :crossed_fingers:

Also that seems weird that what works for everyone doesn’t for you, I would guess you’re doing something wrong. Share what you are doing, your config files, how you have configured the monitor, things like that.

Hey all. I cross-post this to Reddit and found a solution there. It seems like Shift+Alt+F12 solved the issue, which toggles the compositor. So it seems like I needed to toggle it on and off for it to work! Thanks for all your help thus far.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.