Occasional artifacting with burn in ghost images of my windows on the desktop, goes away on reboot?

Is this specific to a video driver maybe? kernel? should I try a proprietary GPU driver instead of open source? not a big deal but happens enough that it seems like it’s something I should fix.

It’s a known bug in kde.


Not much you can do about it, until it’s fixed in kde. You can disable and enable the compositor as a workaround.

You can also disable the “translucent windows” effect. That is also reported to fix the issue.


I have created an alias for this in my ~/.bashrc:arrow_down:

alias restart-compositor='qdbus org.kde.KWin /Compositor suspend && qdbus org.kde.KWin /Compositor resume'

One can also restart the compositor with Alt+Shift+F12.

1 Like

So maybe with a restart it fixes it? interesting.

1 Like

Yes, restarting the compositor cleans out its memory buffer, which is where the ghost images were dwelling.

That said, I have not come across any ghost images yet in Plasma 5.23, so I’m guessing the bug got fixed. 5.23 introduced a whole new rewrite of the compositor, which is why certain desktop effects are currently missing ─ they will be brought back later, albeit that I don’t know when.


Speaking of memory
any tips on going bare bones on memory usage?


I turned off kakuake when it boots and trying to turn off desktop effects. I can add a bigger hard drive if i really wanted but i guess not memory. eg ssd sata should fit (some say ssd will)

(i’m not sure if manjaro benefits from messing around with the paging file or anything other settings)

Well, if you can’t install more RAM into that machine for whatever reason ─ not even if you replace the module(s) already present with a higher capacity one? ─ then perhaps Plasma isn’t the desktop environment for you, and then maybe you would be better off with something more lightweight like OpenBox or LXDE/LXQt. Or maybe even a simple lightweight window manager like i3.


Either way, that’s a different topic. Let’s stick to one thread per topic, please. :slight_smile:

I’m not 100% sure i can increase the module memory size but I read that somewhere.

I made a LXQt installation disk, maybe I’ll try it.

I could also try librewolf instead of firefox but i’m not sure how to install it because last time I tried I thought I had to compile or assemble the package myself.

kde works but it’s not ideal i guess you could say