OBS Studio 'Video Capture Device' Properties Menu Appears Garbled

I previously posted an issue in the OBS studio GitHub here: https://github.com/obsproject/obs-studio/issues/3368

When I follow the steps provided in that link, the UI ends up getting garbled.

One of the contributors in OBS’s GitHub closed the issue, replying that Manjaro is not officially supported by the software and that I should bring this to the attention of Manjaro’s package manager.

I can’t embed media in posts yet in this forum, so I will have to refer you to the link above for a screen shot.

I downloaded OBS using Pamac.


Right, but you can include
inxi -Fxza --no-host

I can notice you are using XFCE and the default theme of OBS, have you tried with System Theme?
Do you have any custom scaling settings?

I just tried it with the system theme and the same issue occurs.

  Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=78fce5c0-25d2-4c26-805d-42d8abde9dfe rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Laptop 15-dy1xxx v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 86C9 v: 56.21 serial: <filter> UEFI: AMI v: F.07 
  date: 10/18/2019 
  ID-1: BAT0 charge: 38.2 Wh condition: 37.9/37.9 Wh (100%) volts: 12.8/11.6 
  model: HP Primary type: Li-ion serial: N/A status: Unknown 
  Topology: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: 78 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23968 
  Speed: 1144 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 1098 2: 1199 
  3: 988 4: 1159 5: 1195 6: 1154 7: 1119 8: 1135 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Iris Plus Graphics G7 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:8a52 
  Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo 
  bus ID: 1-3:3 chip ID: 0408:5365 
  Display: x11 server: X Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) 
  v: 4.6 Mesa 20.1.6 direct render: Yes 
  Device-1: Intel Smart Sound Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:34c8 
  Sound Server: ALSA v: k5.8.3-2-MANJARO 
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8821ce v: N/A modules: 8821ce 
  port: 3000 bus ID: 01:00.0 chip ID: 10ec:c821 
  IF: wlo1 state: up mac: <filter> 
  Device-2: ASIX AX88772B type: USB driver: asix bus ID: 1-1:2 
  chip ID: 0b95:772b serial: <filter> 
  IF: enp0s20f0u1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 953.87 GiB used: 64.01 GiB (6.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 002C scheme: GPT 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 4060 bus ID: 00:17.0 chip ID: 8086.282a rev: 30 
  ID-1: / raw size: 951.07 GiB size: 935.64 GiB (98.38%) 
  used: 63.96 GiB (6.8%) fs: ext4 dev: /dev/nvme0n1p4 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 2.00 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p5 
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 250 Uptime: 2d 14h 38m Memory: 23.25 GiB used: 3.56 GiB (15.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: apt: 0 pacman: 1263 
  lib: 379 flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.05

Remove any other drivers from MHWD UI, and keep just video-modestetting
You might need this lines in /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"

That might add a fluctuating brightness thing, so you have to add to /usr/share/X11/xorg.conf.d/10-quirks.conf this lines at the end:

Section "InputClass"
        Identifier "Spooky Ghosts"
        MatchProduct "Video Bus"
        Option "Ignore" "on"

Edited the INXI for proper formatting

If I remove video-linux, lightdm fails to start.

I ended up having to boot from the live usb and running:

manjaro-chroot /path/to/my/ssd

mhwd -i pci video-linux

to reinstall it.

Now it boots again. I also added the lines to the files you mentioned above and that did not fix the issue either.

But did you installed video-modesetting and added the files before rebooting ?

Yes I did.

Try a different kernel.