OBS Studio uses the mono virtual device to record my mic instead of my actual desktop audio

I updated the pipewire packages to the new versions

[2023-08-11T20:57:50+0200] [ALPM] upgraded pipewire (1:0.3.75-2 -> 1:0.3.77-1)
[2023-08-11T20:57:50+0200] [ALPM] upgraded pipewire-audio (1:0.3.75-2 -> 1:0.3.77-1)
[2023-08-11T20:57:50+0200] [ALPM] upgraded pipewire-jack (1:0.3.75-2 -> 1:0.3.77-1)
[2023-08-11T20:58:10+0200] [ALPM] upgraded gst-plugin-pipewire (1:0.3.75-2 -> 1:0.3.77-1)
[2023-08-11T21:00:04+0200] [ALPM] upgraded pipewire-alsa (1:0.3.75-2 -> 1:0.3.77-1)
[2023-08-11T21:00:04+0200] [ALPM] upgraded pipewire-pulse (1:0.3.75-2 -> 1:0.3.77-1)
[2023-08-11T21:00:04+0200] [ALPM] upgraded pipewire-x11-bell (1:0.3.75-2 -> 1:0.3.77-1)
[2023-08-11T21:00:04+0200] [ALPM] upgraded pipewire-zeroconf (1:0.3.75-2 -> 1:0.3.77-1)

And now obs-studio (29.1.3-1) uses the OBS (Desktop Audio) mono virtual device to record my mic instead of my actual desktop audio. Nothing I change in OBS or gpwgraph fixes this. Both Desktop Audio and Mic/Aux record from the same input device, even though Desktop Audio should follow the “Default Device” non-comms setting which is set to “default_sink” (a virtual devices I created via pipewire config and that virtual device worked just fine for more than 2 years till now).


Expected: The “OBS (Desktop Audio)” virtual device should automatically connect to “default_sink”. That’s how it’s been before this update.

In OBS the Global Audio Devices are configured as shown here:

If I change them to anything other than “Default” or “A50 Mono” (that’s the mic) the OBS created virtual devices (“OBS Desktop Audio” and “OBS-1 (Mic/Aux)” respectively) just disappear.

I actually need OBS only for streaming my desktop audio and video. :frowning:

Edit: cutting the connections in gpwgraph and connecting both “default_sink” channels with the single channel from “OBS (Desktop Audio)” is possible, but “OBS (Desktop Audio)” is only a mono virtual device. I’ve always had a stereo virtual device in the past for recording desktop audio, so that method shouldn’t be considered a workaround since its result is inferior.

Ahh, that’s why my videos today had some noise disturbance

Just want to report that recording stereo desktop audio with OBS works for me once more. I have no idea why it works now and didn’t work two weeks ago. I have not installed any audio related packages in the meantime, it did however run a couple of post-transaction hooks as a result of some other software installations, maybe one of them fixed the problem.

The PC went through several shutdowns and power on between back then and now - could also be that one of those fixed the problem (though I did try rebooting several times back then too).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.