OBS Studio doesn't seem to see my screen in Manjaro GNOME

I’m trying to record my screen and OBS Studio just gives a blank screen when I select my display. I tried other desktop environments and window managers such as i3 and Cinnamon and they worked but I really don’t want to use another desktop environment just to record my screen. What should I do? Thanks.

1 Like

You could use Gnome with X11, you’re defaulting to Wayland probably.

Works fine here on wayland, but you need pipewire installed instead of the manjaro default pulseaudio.
Can’t remember exactly but there were some culprits when installing manjaro-pipewire.
I think installing through yay worked instead of pacman, e.g. yay -S manjaro-pipewire

Why not use the default pamac ? Inviting new user to use tools that they are not aware of, might create more confusion than help them …

pamac install manjaro-pipewire
Or via the Pamac UI that is the most straight forward way to install packages for those that have reticence to use CLI.

Because in this special case Pamac ui failed because of dependency errors and deinstalling pulseaudio at the same time it could not manage.
This may be fixed now.