OBS (Open Broadcaster Software) Not Working On Manjaro Linux 2024


OBS-Studio is not working on my Manjaro GNOME, and I have tried all sorts of installations: flatpak, pacman, yay, and everything I was able to find online.

But OBS is not starting.

I know it runs because my laptop fans are taking off, but nothing happens on screen.

If OBS is not working on Manjaro, can you please recommend me a similar software? (I really do need it for work)


If you are unable to solve this and need it for work and I assume there is a deadline:

If nothing pops up in a search on the forum (I found a few so you can to)


Thank you!

I managed to get it to work by running it in the terminal. (I feel like a complete idiot now :slight_smile: )

I thought I could just click the icon and it will work.

If anybody comes here with the same problem, here’s the solution:

Install OBS

flatpak install flathub com.obsproject.Studio

Run OBS (whenever you want to open it, you must run this in the terminal)

flatpak run com.obsproject.Studio
1 Like

I’m glad you found a workaround, however, installing OBS from the official Manjaro repositories is likely to be less troublesome. You might even be surprised with a launcher to click.

sudo pacman -S obs-studio

(Remove the flatpak version beforehand)


I have tried that before and it is not opening :frowning:

OBS fom the official repositories works without issue here. Your issue is then specific to your setup/configuration; with what precisely, all I can offer is… :person_shrugging: as I don’t have a :crystal_ball:. Good luck with that :four_leaf_clover:.

Flatpak packages (by design) are isolated from any messed up system configurations, so they can sometimes work as expected; at least you have that.

Cheers. :wink:

There was a sale on emoji this week.

:four_leaf_clover: you!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.