OBS Crash at Start Recording with NVENC

I get preview using XSHM as source.

I click start and OBS crashes every time.

Started OBS in terminal to see log of OBS activity.

See dl_fn->cuda_dl->cuInit(0) failed → CUDA_ERROR_UNKNOWN: unknown error

I comb internet for hours looking for resolution for this error, but since its a general error I get tons of resolutions that dont work.

Seeming unrelated post to this actual error but click out of desperation

Tried the resolution:

sudo rmmod nvidia_uvm && sudo modprobe nvidia_uvm

Immediately solved the problem.

If someone could explain why I would appreciate it.

Even though my problem was solved I wanted to post it here in case someone else might need it.

You unloaded and loaded again the module.
Which would indicate there was a problem with it in the first place.
If this is required all the time … then there is some issue with the module or it is not starting correctly.
If it is not … then there was simply a problem with that running instance at that time.
Without logs or further information its impossible to know any deeper ‘how’, ‘why’, etc.

1 Like

What kind of logs are we looking or so I can provide them?

The logs from OBS dont say much. They just end as though it stopped in the middle of normal operation.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.