Nvme suddenly stopped working

Hello I have a problem when i started the pc today it took a long time to start and i got this message

sudo dmesg |grep nvme                                                                                                                                                                                                       
[    9.353828] nvme nvme0: pci function 0000:01:00.0
[  129.856739] nvme nvme0: Device not ready; aborting initialisation, CSTS=0x0
[  129.856749] nvme nvme0: Removing after probe failure status: -19

I don’t know what to do in a liveusb I was able to get this information

sudo lspci |grep -i ssd 
01:00.0 Non-Volatile memory controller: Silicon Motion, Inc. SM2263EN/SM2263XT SSD Controller (rev 03)

Hello @juanda097 and weclome :wink:

Probably this helps: https://wiki.archlinux.org/title/Solid_state_drive/NVMe#Controller_failure_due_to_broken_suspend_support

How do I do this?

As a workaround, add the kernel parameter iommu=soft to use a software replacement for the IOMMU hardware. (See this documentation for details.) This may cause a slight processing overhead.

I’m a bit of a noob

  1. Boot a Manjaro Live Session.
  2. Open a terminal window and chroot into the local installation
sudo manjaro-chroot -a

If it is btrfs, you need to mount it beforehand, since it cannot be detected automatically.

  1. Open the GRUB configuration file for editing. You can do this by running the following command with administrative privileges:
sudo nano /etc/default/grub

This will open the GRUB configuration file in the nano text editor.

  1. In the GRUB configuration file, locate the line that starts with GRUB_CMDLINE_LINUX_DEFAULT. This line contains the default kernel parameters used by GRUB. It may look something like this:
  1. Append iommu=soft to the list of kernel parameters within the double quotes. Make sure to separate it from other parameters with a space. For example, the updated line should look like this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=soft"
  1. Save the changes and exit the text editor (in nano, you can do this by pressing Ctrl+O, followed by Enter to save, and Ctrl+X to exit).
  2. Update GRUB with the new configuration by running the following command:
sudo update-grub
  1. Reboot your system for the changes to take effect:
sudo reboot

After rebooting, the iommu=soft kernel parameter should be added and active during the boot process. You can verify this by checking the kernel parameters using the cat command, like this:

cat /proc/cmdline

You should see iommu=soft listed among the kernel parameters.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.