Nvidia X Server Errors

Hi guys pretty new to Manjaro and Linux in general. I am having some issues that I am not sure if they are normal or not.
I installed Manjaro with Proprietary Drivers for my RTX 3090, Driver version is 465.31

Everything is working just fine but I was following the wiki and started to do the setup for the Nvidia X server.
I am running the command sudo nvidia-settings, as soon as I do this I get this message on the terminal screen. a few places said this is normal? The Nvidia settings GUI opens just fine.
Here is said message

“(nvidia-settings:15304): GLib-GObject-CRITICAL **: 21:58:21.259: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed”

Now I then go into the settings and set it up how I would like, I click save to X configuration file and then the instant I hit browse to go to etc/X11/mhwd.d/nvidia.conf I get a whole bunch of errors on the terminal window.

I am not sure if this is normal or I am doing something incorrectly but any help would be appreciated.

Forgot to mention I am using Gnome


There is an already general setup made once you installed the driver via MHWD, no need to change anything unless is not working, or you need a particular config.

So, you need a particular config?

That is a warning you can ignore, is there since forever … but please don’t use sudo nvidia-settings
If you want to save your particular settings that will not be ok, as the .nvidia-settings-rc will inherit root permissions hence fail to load on your user. If you want to save the config, use the Preview from nvidia-settings > copy the text and then Edit as Administrator your etc/X11/mhwd.d/nvidia.conf - but please do it wisely, or if unsure, share it here so someone can help you out.

OK, I was just going by what the Wiki says to do.

So technically I can just change my resolution in the settings and my refresh rate and not really ever need to mess with nvidia-settings I assume other than anytime I may want to disable Gsync and even then all I should have to do is disable it and apply and exit I assume.

I guess the reason I was in there to begin with is to try and see if I can enable 10 bit color. My Display is a LG CX OLED and in Windows I am able to run full 3840x2160@120hz with 10 bit color enabled and having 10 bit enabled makes the display look much better.

I am not seeing an option to let me use 10 bit. I tried some tutorials that said change the value for Default depth to 30 and the Depth to 30 but I did not notice any difference and the display still says it in 8 bit mode.

I know, but sometimes people are saving the .nvidia-settings-rc while they used sudo and that is what i wanted to point out. If you followed each step as described there, and opened as your user the Nvidia X Settings and you saved the .nvidia-settings-rc then is all good.

In the etc/X11/mhwd.d/nvidia.conf you cange this

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24

to this

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 30
SubSection "Display"
Depth 30

but some applications might have a broken UI because of that …

OK thank you for the information, I may just do a fresh install tomorrow that way I can rule out anything I may have messed up. It doesn’t take long and I don’t have anything important on the machine at the moment anyway.

I made that change in the folder as that is the way I had tried before but for me it doesn’t seem to do anything at all except cause issues with some apps.
My display I can bring up a menu and it will tell me which color depth signal it is getting and what it is running and even with it set to 30 in the config the display still says it’s at 8 bit.
I don’t think I am going to worry with it for right now though.

Thank you for your help.

Wanted to add to this with another slight “issue” I am having.
So running Gnome as my DE and I have my settings set to 120hz for my display. What I am noticing is on the Desktop my mouse movement is nice and fluid just like 120hz should be and just like it is on Windows.
The issue I have is when I move windows around on the Desktop, the windows will Stutter/Drop frames and generally do not feel very fluid.
For testing purposes I did a new fresh install and instead this time installed KDE Plasma DE and it did not have that issue, moving windows around the Desktop was smooth as butter with no stuttering or so called frame drops.

I really do not prefer KDE Plasma and would like to stick with Gnome. Is there anything I can check while I am on Gnome? From my research this is a compositor issue?