Nvidia settings: Unable to load info from any available system

After I installed envycontrol and switched from intel to hybrid my nvidia settings in the system information tab only shows driver version and nvml version and powermizer tab is completely gone.

inxi -F

  Host: vidakov-laptop Kernel: 5.17.15-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.6 Distro: Manjaro Linux
  Type: Laptop System: HP product: HP Pavilion Laptop 15-eg0xxx
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: HP model: 8850 v: 34.31 serial: <superuser required> UEFI: Insyde
    v: F.30 date: 03/11/2022
  ID-1: BAT0 charge: 38.8 Wh (95.3%) condition: 40.7/40.7 Wh (100.0%)
  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    cache: L2: 5 MiB
  Speed (MHz): avg: 746 min/max: 400/4700 cores: 1: 710 2: 922 3: 1048
    4: 602 5: 1067 6: 477 7: 519 8: 626
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce MX450] driver: nvidia v: 515.57
  Device-3: Luxvisions Innotech HP Wide Vision HD Camera type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: modesetting unloaded: nvidia gpu: i915 resolution: 1920x1080
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.3
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
    driver: sof-audio-pci-intel-tgl
  Sound Server-1: ALSA v: k5.17.15-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8822ce
  IF: wlo1 state: up mac: 64:6c:80:26:38:43
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
  Local Storage: total: 476.94 GiB used: 322.09 GiB (67.5%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8H size: 476.94 GiB
  ID-1: / size: 468.09 GiB used: 322.06 GiB (68.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 32.3 MiB (10.8%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 236 Uptime: 7m Memory: 15.4 GiB used: 2.44 GiB (15.8%)
  Shell: Zsh inxi: 3.3.19

Edit: I’ve installed nvidia driver 470.129.06 and when I run nvidia-settings I get this

ERROR: Unable to load info from any available system

Fixed it.
I had to remove everything form


on next update kernel you will have some trouble on video
can you report

sudo mhwd-kernel -li
sudo mhwd -li 

very few laptops can only works with only nvidia videos cards( dedied pci ) ,
you have to use hybrid version , and in that case it’s intel or amd apu running ,
see more prime run for nvidia cards


Currently running: 5.18.12-3-MANJARO (linux518)
The following kernels are installed in your system:
   * linux515
   * linux517
   * linux518


> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

Also when I was running Ubuntu I was able to switch to nvidia only with no problems

can you remove kernel517, this EOL

sudo mhwd-kernel r linux517
1 Like

Ok I removed the kernel.