NVIDIA settings not run after reboot

I’ve followed the steps that are posted on the wiki (Configure NVIDIA (non-free) settings and load them on Startup) but whenever I restart my computer the settings are never loaded. Only when I run “nvidia-settings” from the terminal are the changes I made applied.

Not only that, but every single time after I turn on my computer one of my external drives will not mount automatically at random. This has only started happening after changing nvidia-settings and I have no idea whats going on.

I just want my changes to be applied automatically after I turn on my computer… Any idea what’s going on?

To save the settings, you’ll need to run sudo nvidia-settings, make your changes then click Save to X Configuration File. Click Browse and save it to /etc/X11/mhwd.d/nvidia.conf.

2 Likes

Thank you very much for you reply (and sorry for the belated response).

I followed your instructions and rebooted my machine and was greeted with a black screen. I nearly went apoplectic because I thought I completely bricked my computer. Fortunately I was able to find a fix here and everything is back to normal.

I guess the lesson I learned here is that trying to use Linux with an NVIDIA GPU is a terrible idea. I’ll just live with this issue from now on until I can get an APU or a Radeon GPU if that makes a difference. Thanks for the help though.

Double posting to pin the solution on the OP. After changing the settings step by step from the instructions on this wiki page, I added “Nvidia X Server Settings” to the applications that start up when logging in.

Not the solution I was hoping for, but at least it works.

You don’t have to load anything at boot. If you save your changes through Nvidia Settings with sudo to the proper config file, they will be the defaults when you boot.

1 Like

Changing what exactly?

That did absolutely nothing. Disable that and reboot, settings will still be applied if you followed the wiki / what I said above.

1 Like

I did exactly that. I followed the steps on the wiki page (section " Configure X Screen settings (OpenGL Settings, Antialiasing, X Server XVideo)") and the settings I changed would not load when logging in. The only way I could make them load when logging in was the method I explained earlier.

I followed the steps on the wiki page to a T, I double checked everything to make sure I didn’t mess up and nothing.

Except it does. This was the only way I could make the settings take effect after booting up, so I don’t know why you’re saying it did absolutely nothing when it in fact did. I mean, it’s worked like a charm for the past couple of days so how can you tell me it’s not doing anything when I’m seeing quite the opposite myself?

The point that I was making was that following the wiki steps solved the issue, not enabling the NVIDIA Settings GUI application to load at startup. If I understand correctly, you did both at the same time. I invite you to disable it from loading at startup and see if it makes any difference.

No, I didn’t do both at the same time. I made the Nvidia Config window open when booting up after following the steps from the wiki and having no changes being made. I checked and restarted my PC around 5 times with no luck. They would only show up after starting Nvidia Config after a reboot, which is why I made the app start automatically because there was no other way of making the changes I made take effect.

Oh, I see. That doesn’t make any sense as opening NVIDIA Settings manually to check if the settings were applied is the same thing adding it to startup applications.

How did you add it to startup? What command is being used?

System Settings > Startup and Shutdown > Autostart > Add… > Add Aplication > NVIDIA Settings Manager

I even went back to the wiki article, double checked I did eveything right and I still had the same problem. Changes would only take effect when launching the NSM. Adding it to the Autostart applications is just a bandaid I managed come up with since nothing else worked for me.

Like I said before, best solution I can think of is to not use NVIDIA with Linux in the first place. That’s what I get for coming from Windows I guess…

I don’t understand how that is magically working for you. I assure you, the instructions already given work for everyone else without adding anything to startup. I think there’s something we’re missing here and it will dawn on you one day. Then you’ll come back to this post to add your revelation and find it was automatically closed due to inactivity. If that does happen, PM me and we can update it. :wink:

Indeed, but the selection of laptops with dedicated AMD graphics is limited. I bought my current laptop for development in mind, graphics came second.

At least now I can roll with the punches with NVIDIA driver updates and help assist others. My old laptop has an AMD APU.

I’ve gone back and checked the wiki article about 10 times now (probably more) since making the original post. Everything is configured correctly and in theory should work, but doesn’t.

In any event, I already went out and bought an APU since I pretty much don’t use my GPU much nowadays and have had zero issues so far. I probably won’t be updating this thread or sending you a PM because I’m done using NVIDIA products. Hell, even when I was building my PC I didn’t want to get an NVIDIA GPU but had to settle with a 1050 Ti because it was the best option I had available at that time.

So if anyone is reading this, the best advice I can give you is to NEVER use nvidia products when running Linux. Linus himself said it best, after all…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.