Nvidia settings not loading on startup

I’ve done some tweaks in nvidia-settings (Vblank and allow flipping to off) and to the /etc/environment file to enable the 144hz on my monitor (my second monitor is 60hz). It’s working fine all animations are runnning at max fps but after a reboot everything fells apart (windows and animations are capped at 60hz). The only way to fix it is to launch nvidia-settings and everything goes to normal. Also I’m experiencing some flickering in the top part of my monitors. It’a a black square flashing for milliseconds and it goes away.

Here is the /etc/environment:


And this is my /etc/X11/xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 530.41.03

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AOC 24G1WG4"
    HorizSync       160.0 - 160.0
    VertRefresh     48.0 - 144.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA GeForce RTX 2060"
    Option         "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DP-0: 1920x1080_144 +1440+0 {ForceCompositionPipeline=On}, HDMI-0: 1440x900_60_0 +0+180 {ForceCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

My Flicker solution.

Did you reinstall “nvidia-settings” in pamac also? xserver is removed from nvidia-utils and required nvidia-settings since last stable update.

I remember I reinstalled nvidia-settings with pacman at some point. From where should i download it?

You have installed last stable version, right?

Normaly the nvidia xserver tool vanished after the last stable update and you have to reinstall it with, nvidia-settings from the official repo, you can download it with pacman.

If you see xserver in the taskbar under Settings>nvidia x server settings… then you fine.

You talking about xserver here, right?

If this is the case, you can create a little bash script that i also use:

nvidia-settings -l

But you can also add something like this in autostart… if you dont like to double click on a icon, everytime when you loading at the desktop.

That didn’t fix it for me, I created an nvidia-fix.sh file and run it as an executable but nothing changed, I tried just running “nvidia-settings -l” in the terminal but nothing happens.

It would help alot, if you could give me more detailed answers.

What are you doing after a system restart now? Step by step.

Are you just start xserver and everything is fine? or you changing after every restart your files or settings in xserver?

I startup my pc and boot into manjaro,i log in and my animatons and window movements are capped at 60hz, then i type in the console “sudo nvidia-settings” and then the 60hz cap is removed. I am not doing anything. I’m just starting up nvidia-settigs, then i quit it.

I hope you could atleast fix your black flickering yet.

The command nvidia-settings -l just loads your settings that is stored.

i have no idea why you need sudo for that, i think at this point im out of ideas.

I have one last option, you can go in system settings>startup and shutdown>autostart

1.Add Application nvidia x server
2.In command /usr/bin/nvidia-settings -l