NVidia Prime broken after update

Hi. I’m using laptop with Manjaro Linux on kernel 5.10.4-2. My config is next:

  • AMD Ryzen 5 3550H with Radeon Vega 8
  • NVidia GeForce GTX 1650 Mobile Max-Q

My drivers are video-hybrid-amd-nvidia-prime, with mesa driver for amd, and for nvidia were nvidia 455.45.01-2 (at least yesterday). Yesterday prime-rendering worked perfectly, and I’ve used my discrete card in some applications, but I have updated system, and today all prime application was broken, because nvidia driver is unloaded I don’t know why. Update before 2021-01-01T14:00:00Z was at 2020-12-28T14:00:00Z. NVidia-SMI gives me next information:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

My pacman update log for this two days looks next (Gist GitHub). Interesting fact that there is no packages called like “linux510-nvidia” installed automatically after switching kernel (it was maybe week ago), but maybe it was need to be installed, etc, and I’m impressed that this works perfect in “linux59-nvidia” with kernel 5.10 (but also it can be my fault). Also, grep of installed packages with nvidia in my system:

@jentu ➜ ~ pacaur -Ss nvidia | grep installed
core/mhwd-nvidia 455.45.01-3 [installed]
core/mhwd-nvidia-390xx 390.138-1 [installed]
extra/libvdpau 1.4-1 [installed]
extra/linux59-nvidia 455.45.01-6 (linux59-extramodules) [installed]
extra/nvidia-prime 1.0-4 [installed]
extra/nvidia-utils 455.45.01-2 [installed]
extra/opencl-nvidia 455.45.01-2 [installed]
community/cuda 11.2.0-2 [installed]
community/cuda-tools 11.2.0-2 [installed]
multilib/lib32-libvdpau 1.4-1 [installed]
multilib/lib32-nvidia-utils 455.45.01-3 [installed]
aur/mhwd-nvidia 455.45.01-2 (1, 0.00714500) [installed: 455.45.01-3]
aur/mhwd-nvidia-390xx 390.138-1 (0, 0.0) [installed: 390.138-1]

Maybe I have too much unnecessary packages, or something else. Does you have any ideas or recommendations?


Have you tried to install this package?

Yes, now I’ve installed this package, and this fixed. But why this isn’t installed with kernel, idk.

Well Manjaro is going through some rearrangements and it affects the way Nvidia drivers are packaged and delivered, so you were hit by a temporary (I hope so) bug.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.