Nvidia NVENC not working with applications

Simply do this:

downgrade x264 ffmpeg

choose x264-3:0.159.r2999.296494a-1
choose ffmpeg-2:4.2.4-1

The correct order is important!

1 Like

Thanks for reply, but!
i cant use these commands on terminal
i switched obs to software encoder in advanced setting it worked

1 Like

you need to first install downgrade with either pacman or pamac if you don’t have it installed, and then run the command again.

$ pamac install downgrade

1 Like

This worked for me. Thanks!

1 Like

Thanks that fixed it.

1 Like

hey did any one of you used davinchi resolve 16
i got an issue with it
it just opens and automatically closes on startup
is there any possible fix

i am using kde plasma
i have installed downgrade earlier but finally my system crashed after downgrade
i have re installed entire os again
now i set a timeshift backup
doesnt matter
but there are now nvidia 450 drivers in arch repo
i think when these drivers get updatedNVENC will work

450 is already in Testing and reached Stable-staging yesterday I think, it is coming soon to Stable.

Worked for me, thanks!

i have found a way to install nvidia
in this forum some where but i forgot to book mark
but i have commands in my history
i am using a nvidia 1660 ti mobile (optimus laptop with intel integrated gpu and 1660ti mobile) i ran into similar issues but installed finally
OBS studio is also working with NVENC
to update

IMPORTANT:: update all packages before doing and reboot
without updating all packages and kernels
-------------------------> you cant install nvidia - 450 without updating the existing packages
–>update packages before doing this

NOTE : remove the current drivers using MHWD command line and install

  1. sudo mhwd -i pci video-modesetting (or your driver name)
  2. sudo mhwd -r pci video-hybrid-intel-nvidia-440xx-prime (or your driver name)
  3. sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime (or your driver name )
  4. reboot

thats it
it worked for me

Is there a solution for hybrid graphics for this? Cause I’ve tried everything suggested and NVENC still won’t work. Here’s my system info:

  Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A Desktop: LXQt 0.15.1 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Laptop 15-da0xxx 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: HP model: 84A7 v: 80.28 serial: <filter> UEFI: Insyde v: F.04 
  date: 08/02/2018 
  ID-1: BAT1 charge: 42.3 Wh condition: 42.3/41.0 Wh (103%) 
  model: Hewlett-Packard PABAS0241231 status: Full 
  Topology: Dual Core model: Intel Core i3-7020U bits: 64 type: MT MCP 
  arch: Amber Lake rev: 9 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 18406 
  Speed: 800 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard 
  driver: nvidia v: 450.57 bus ID: 01:00.0 
  Device-3: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD Camera 
  type: USB driver: uvcvideo bus ID: 1-5:3 
  Display: x11 server: X.org 1.20.8 driver: modesetting,nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce MX110/PCIe/SSE2 v: 4.6.0 NVIDIA 450.57 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.8.1-3-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A port: 3000 
  bus ID: 03:00.0 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 931.51 GiB used: 11.56 GiB (1.2%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:17.0 
  ID-1: / size: 907.45 GiB used: 11.56 GiB (1.3%) fs: ext4 dev: /dev/sda2 
  ID-1: swap-1 type: partition size: 8.28 GiB used: 0 KiB (0.0%) 
  dev: /dev/sda3 
  System Temperatures: cpu: 51.0 C mobo: 29.8 C gpu: nvidia temp: 54 C 
  Fan Speeds (RPM): N/A 
  Processes: 174 Uptime: 1m Memory: 3.76 GiB used: 542.0 MiB (14.1%) 
  Init: systemd Compilers: gcc: 10.1.0 Packages: 1061 Shell: Zsh v: 5.8 
  inxi: 3.1.05 

Is the ffmpeg/nvenc still broken? Downgrading and switching to the testing branch didn’t work but x264 did. That’s using the CPU and I’d rather not do that… My system is still rolled back to kernel 5.6 for now. I’ve upgraded but again, only the x264 only work and not the nvenc.

Maybe a fresh install will fix this.

NVENC (at least in OBS) seems to work with the 450.xx series driver and ffmpeg n4.3.1, on Linux 5.4.

Yeah, I’m still on 440.

So you’ve upgraded just ffmpeg and the drivers only, right? Also you used mhwd or directly from NVIDIA’s drivers?

I don’t exactly remember, I switched to a different branch at about that time. I used mhwd.

There doesn’t seem to be a 4.2.4 option when I try to do it, so I tried 4.3.1 (which I think someone mentioned worker for them) and it gives me the error:

error: failed to prepare transaction (could not satisfy dependencies) :: unable to satisfy dependency 'libx264.so=160-64' required by ffmpeg

It’s been more than a month and you’re still struggling guys?
I have Nvidia 450 (removed 440 then installed 450 from KDE’s System Settings / MHWD), and I have OBS, I can record with NVENC without any issue. I don’t understand why you’re still trying to figure out how to downgrade to Arch’s old package when it was never needed, this has been quickly fixed (couple days for sure on Testing branch) by pushing 450 drivers to Stable after the issue has been identified.

I don’t want to use the Testing Branch. Things have been fine up until this last big update.

Looks like the best route for me was use update the kernel first (take a system snapshot). Upgrade the video drivers (take another system snapshot). Do a full upgrade and here I am stream again on the stable branch.

Maybe this will work for others, hopefully, but I’m sure everyone’s mileage will vary…

for those who are still having issues, what worked for me was to use the lts kernel again (5.4).
as soon as I installed it and removed the newer ones (I was using 5.9 with 5.8 as fallback), everything worked flawlessly :]