Nvidia Issue with Manjaro

How do I get to desktop so I can install nvidia driver? It keeps hanging up at video load on startup. I’ve tried both open source drivers and priority drivers. Have a geforce 9600 gt 512mb in it. It says [OK] Reach target graphical interface and just hangs there. I have hit ‘E’ and tried setting nouveau to 0 and still stops at the graphical interface. I was told to maybe use prime hybrid but not sure how to do that. Every distro of Linux I try to install halts at nouveau to vesa vga except for Fedora 15. The latest Fedora hangs up too.

since you cant boot any distro, go to bios and check:
secure boot needs to be disabled
fast boot needs to be disabled - you may not have this option
AHCI needs to be enabled
fast startup needs to be disabled in windows

use Ventoy to flash the iso

in your UEFI motherboard

disable secure boot
disable fastboot
disks on AHCI all
no legacy
no CSM
UEFI only or others ( not windows )

if you can boot on USB live manjaro
choose for UEFI < USB name vendor > < partition 1 > to boot for install

choose non free drivers and you langage / keyboard before boot

after booting

open a terminal and a browser on this topic
and returns

inxi -Fza ( check for UEFI only , not UEFI[legacy] or Bios )
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
sudo efibootmgr -v
1 Like