Nvidia GT430 window flickering

Hi, I observe windows which start flickering after a while, i.e. after reboot everything is fine and after a certain time, the flickering starts. At some point the system becomes quite unusable and has to be rebooted.

Can someone give me advice?


inxi -Fxza --no-host:

System:    Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
           root=UUID=767fe390-f592-47e5-a65b-1536500daae4 rw quiet apparmor=1 security=apparmor 
           Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: B75MA-P45 (MS-7798) v: 1.0 serial: <filter> 
           UEFI: American Megatrends v: 1.9 date: 09/30/2013 
CPU:       Info: Quad Core model: Intel Core i5-3450S bits: 64 type: MCP arch: Ivy Bridge family: 6 
           model-id: 3A (58) stepping: 9 microcode: 21 L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22408 
           Speed: 1600 MHz min/max: 1600/2800 MHz Core speeds (MHz): 1: 1600 2: 1600 3: 1600 4: 1600 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GF108 [GeForce GT 430] driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:0de1 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nouveau 
           unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: DVI-I-1 res: 1920x1080 hz: 60 dpi: 96 size: 510x287mm (20.1x11.3") 
           diag: 585mm (23") 
           OpenGL: renderer: NVC1 v: 4.3 Mesa 20.2.1 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Micro-Star MSI 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
           Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0bea 
           Sound Server: ALSA v: k5.9.3-1-MANJARO 
Network:   Message: No Device data found. 
           Device-1: NetGear WNDA4100 802.11abgn 3x3:3 [Ralink RT3573] type: USB driver: rt2800usb 
           bus ID: 2-4:2 chip ID: 0846:9012 serial: <filter> 
           IF: wlp0s20u4 state: up mac: <filter> 
Drives:    Local Storage: total: 2.96 TiB used: 1.29 TiB (43.6%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 4B6Q scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WD5000AZRX-00A8LB0 size: 465.76 GiB 
           block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 1A01 
           scheme: GPT 
           ID-3: /dev/sdc vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: 
           physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 1B6Q scheme: GPT 
           ID-4: /dev/sdd type: USB vendor: Toshiba model: External USB 3.0 size: 931.51 GiB 
           block size: physical: 512 B logical: 512 B serial: <filter> rev: 5438 scheme: GPT 
           ID-5: /dev/sde type: USB vendor: Western Digital model: WD Elements SE 25FE 
           size: 931.48 GiB block size: physical: 512 B logical: 512 B serial: <filter> rev: 1021 
           scheme: GPT 
Partition: ID-1: / raw size: 232.59 GiB size: 227.94 GiB (98.00%) used: 66.76 GiB (29.3%) fs: ext4 
           dev: /dev/sda2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 50 (default 100) 
           ID-1: swap-1 type: file size: 8.00 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 43.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 234 Uptime: 2m Memory: 7.71 GiB used: 1.05 GiB (13.6%) Init: systemd v: 246 
           Compilers: gcc: 10.2.0 Packages: 1468 pacman: 1456 lib: 386 flatpak: 9 snap: 3 Shell: Bash 
           v: 5.0.18 running in: konsole inxi: 3.1.08

It’s recommended to use the non-free driver. Do the switch :wink:

Storm, thanks for the quick reply!

… Ok. I’ve tried by downloading the driver from nvidia. During installation I was prompted to accept a modprobe and then reboot. Unfortunately the display disappeared. I therefore booted into Manjaro Live! and removed the modprobe. So far only 20 minutes of sweat! Manjaro still pretty cool!

However, further reading at nvidia tells that it might get complicated to replace noveau with the proprietary driver. Can you give me a brief instruction?

BTW: I could not install the driver via the hardware gui:

Waiting for user input…


Installing video-nvidia-390xx…

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-390xx/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

Processing classid: 0302

:: Synchronizing package databases…

error: target not found: linux59-nvidia-390xx

core is up to date

extra is up to date

community is up to date

multilib is up to date

Error: pacman failed!

Error: script failed!


after that…

why you are doing that to yourself… you are using Manjaro, which makes it so much simpler and cleaner to switch/install drivers (Configure Graphics Cards - Manjaro). You shouldn’t install drivers from nvidia directly unless you are already familiar with Manjaro’s mhwd system architecture and really-really know what to do beyond that… starting with the basics that Manjaro is a rolling distro and you can’t just install whatever Nvidia driver version comes to your mind, unless you like… pain.

tuxmanjarino, thanks for the quick reply!

I tried as follows:

sudo mhwd -a pci nonfree 0300

Installing video-nvidia-390xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-390xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronisiere Paketdatenbanken…
Warnung: nvidia-390xx-utils-390.132-1 ist aktuell – Überspringe
Fehler: Ziel nicht gefunden: linux59-nvidia-390xx
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
Error: pacman failed!
Error: script failed!

I also tried to switch to lts kernel 5.4 with the same result.

It seems the source is not available. Any idea?

Check this thread:


I found the problem: Switching kernel to 5.4 while having 5.9 installed would not allow to fetch the correct driver. Instead I had to remove kernel 5.9 completely. Then it is possible to simply install via hardware configuration menu.

I hope this solves my flickering window problem.

For the future I learned that I should consider to dump the graphics card in order to stay updated regarding kernels. Right?

Thanks again!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.