Nvidia Force Full Composition Pipeline setting not saving

I installed XFCE Manjaro yesterday and I was having an issue with my g-sync monitor not display the correct refresh rate (165 hz). I was able to fix it by enabling “Force full composition pipeline” in nvidia-settings. However after every reboot, the setting is disabled and I have re-enable it again manually. I tried setting the option as a startup script through systemd and the autostart folder but to no avail. Any suggestions?


What you have to do is to add it to the config file in /etc/X11/mhwd.d/nvidia.conf

It can be added to Section "Device" but also can be added to Section "Screen" but that in case you create a fixed layout. See that entire comment so you understand the context and do not pay attention to the kwin related part.

It worked. All I did was add change the given line with the same line provided from the xorg.conf file generated by nvidia-settings. Thanks a ton.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.