NVIDIA Drivers - RTX 3060 -

Hey there, good morning/afternoon for you!

I just did that and still:( but you know something weirddd haha yesterday I was able to ‘switch’ from integrated to dedicated by just using the terminal comms for optimus but today it is not working, what I did yesterday was to run (in this order):

optimus-manager --help
optimus-manager --status
optimus-manager --print-mode
optimus-manager --print-startup
optimus-manager --switch nvidia --no-confirm
and then it logged out super quick and I was able to log back in with nvidia running… today it is not happening.

Optimus still does not appear on the tray, maybe it has something to do with optimus?

if you reinstalled the nvidia drivers and then you tried switching via optimus commands, it will not work, so remove optimus, install it again, reboot and switch via commands… i have no idea why its not working on your machine…

I tried that before reading your post:(
I reinstall optimus after reinstalling nvidia, tried with commands but nothing :cry: :sob:

so uninstall optimus, reboot and post output from:
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"
to check for leftover congigs, and we try another switching method… but since prime-run doesnt work, im thinking its something with nvidia and your ‘tinkering’ …

Hey there, thank you for keep trying, you deserve heaven at this point! <3!
I just did what you suggested, here is the output:




looks ok, so install envycontrol:
pamac build envycontrol
when done installing, switch to nvidia:
sudo envycontrol -s nvidia
it will prompt you for reboot, so do it and see…
if you end up with a black screen, enter in the black screen into TTY: ctrl+alt+f2 or f1-f6 keys, enter your username and password, and uninstall it:
sudo pacman -Rcns envycontrol
systemctl reboot

Good news!! Using this method has worked switching to Nvidia graphics card!
Bad news… switching back to dedicated sudo envycontrol -s dedicated returns error and recommends switching back to hybrid first… I did sudo envycontrol -s hybrid and it is a black screen, tried what you recommended but it won’t exit from the black screen.

I tried installing back envycontrol but it returns an error for temporary name and ‘can’t find the file.’

did you rebooted after you had run?:
sudo envycontrol -s hybrid

yup, I did

so i dont know whats wrong…
boot into manjaro live usb, boot it with proprietary drivers, and run there:
prime-run firefox
then run:
to see if it runs on nvidia

I’ll try this!

And if it still does not work, I’ll re install manjaro again

well if it doesnt work in the live usb, theres no need to reinstall…

A post was split to a new topic: Tengo problemas con la Nvidia