NVIDIA Drivers not working on Dell XPS 9560

So I have been avoiding this issue for a while, but now that I want to game more seriously on my distro, I was hoping to use the proprietary NVIDIA drivers on my Dell XPS 9560. I have a very vague memory (which I have probably mentally blocked because of the trauma) of having issues with NVIDIA drivers and ended up using the free drivers.

Fast-forward to the other day, I decided to install the nonfree drivers by using

sudo mhwd -a pci nonfree 0300

The result of this is the DE hangs on boot (or at least I assume that is what is happening, it stays at a black screen, although I am able to enter a shell by entering CTRL+ALT+F4).

I have tried installing different drivers suggested by the output in

sudo mhwd -l

But it always results in the computer booting up to a black screen.

Any help would be appreciated. I am pretty comfortable doing anything except for reinstalling seeing as I wasn’t smart enough to put my /home in its own partition and it will end up being a massive hassle…

Thanks in advance!

Hello @christopolise :wink:

I wrote a script to collect necessary information. It might be easier…

This will collect information and just display the information:

curl -s "https://gitlab.com/-/snippets/2174072/raw/main/gpu-report.sh" | sh

This will collect information, display the information, and after quitting by typing Q, it will also upload it and print a link:

curl -s "https://gitlab.com/-/snippets/2174072/raw/main/gpu-report.sh" | sh -s -- upload

Post the Link here or copy&paste the information here as code.

The output of the tool can be found at 0x0.st/-xEY.txt (Had to exclude the https:// part because I keep getting told that I can’t put links in the post…)

1 Like


ok well at the moment only open source driver are installed:

  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell 
  driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1c8d class-ID: 0302 

But you have hybrid gpu, so I assume you have to install this:

sudo mhwd --install pci video-hybrid-intel-nvidia-prime

Beside that, you have a xorg config. This will be a problem on a hybrid gpu, because Intel should be used for xorg and not nvidia. Nvidia will be used for offloading applications. Remove it:

sudo rm /etc/X11/xorg.conf

:warning: Note also this: In the past there were problems with hybrid gpus with GDM. You will have to add i915, so the intel driver for early load:

Replace MODULES=() (or MODULES="") with:


at /etc/mkinitcpio.conf with an editor.

Then run sudo mkinitcpio -P to update the initramfs.

If you want to use Nvidia as main (and completely ignore intel), then you have to install:
:warning: Keep sure that you removed video-hybrid-intel-nvidia-prime before:

sudo mhwd --remove pci video-hybrid-intel-nvidia-prime
sudo mhwd --install pci video-nvidia

Note this: mhwd will create a nvidia config at this task. If there is a config file at /etc/X11/xorg.conf, then xorg will take this one and ignore all other at /etc/X11/xorg.conf.d/

Also for easier switiching between Intel and Nvidia on a full desktop, use optimus-manager.

You can offload applications/games by running it with prime-run my-game-binary or in steam startup options: prime-run %command% on a hybrid setup.

1 Like

This worked! I guess the thing I didn’t know that I needed the i915 module when it came to to GPUs. Everything worked like a charm. Thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.