NVIDIA drivers acting very weird I don't know how to fix

I installed Manjaro today. Something weird I’ve noticed is that it would not show the GNOME DE, instead it would be stuck on my boot logo, until I switched to TTY2 and then to TTY1 where the login screen would finally appear.

I then noticed I was using my integrated graphics for things that the GPU would be fit for better. I tried installing the driver “video-nvidia” in the hardware configuration in Manjaro Settings. After rebooting the workaround I outlined earlier was not working, instead the screen would freeze as soon as I switched to TTY1 with the previous thing that it was displaying.

I’m guessing this was probably the DM having issues with the driver. So what I did was I used the command:
sudo mhwd -r pci video-nvidia

This allowed me to boot back this time without the workaround and reinstall the driver I had initially. nvidia-settings look empty, the column only has these items:

  • GPU 0 - (GeForce GTX 1060)
    • Thermal Settings
    • PowerMizer
  • Application Profiles
  • nvidia-settings Configuration

I am so confused, why can’t I install NVIDIA driver?

You need the hybrid driver if you have dual GPU.

But then how can I run a game using NVIDIA? Also does that mean that video-nvidia appears in hardware config without it actually being compatible?

It is compatible, in specific cases, sometimes you can get away with just using pure Nvidia drivers on an hybrid setup (I think most likely on a desktop computer, where the integrated graphic chip is not a vital component of the system), apparently it doesn’t work at all for you (laptop?), you NEED the hybrid driver.

Also about all your questions it is explained in the wiki: Configure Graphics Cards - Manjaro

EDIT: also sometimes you can disable the integrated chip in the BIOS to have just the Nvidia card working, this way you have pure Nvidia setup and don’t need hybrid driver.

Ah I see, thanks for the clarification, but there is still this problem:

When I boot my PC it shows the ASUS logo, and then nothing, it just freezes like that, until I switch to tty2 and then back to tty1, then I see the Gnome login screen. What causes this? On Ubuntu, it would show the ASUS logo and then the Ubuntu logo while it was loading. What’s more, if I hold the power button when the ASUS logo is frozen, the Manjaro loading logo pops up for 1 second playing the loading animation and then it shuts down… This is so weird I don’t even know how to fix this…

You installed the hybrid driver? If yes then yes there is a problem, if no, probably the current video driver used is not working properly, in this case, access another TTY and install the hybrid driver from terminal.

Same wiki page: Configure Graphics Cards - Manjaro

Currently my graphics drivers are the way they were by default. That problem was the reason I thought that I should switch to just NVIDIA. I currently have the hybrid driver, as soon as I installed the video-nvidia one, gnome wouldn’t start, so I reinstalled the “video-hybrid-intel-nvidia-prime” but the issue I outlined with the ASUS logo and switching tty2 and back to tty1 still exists… So is there a way to fix that problem where the login screen won’t show automatically?