Nvidia driver problems - Geforce 720M (2)

Hello. I put a (2) in the title because I have already seen Nvidia driver problems - Geforce 720M but I need guidance. I installed in the past countless of packages that supposedly activated the driver but they don’t. I have never been able to use the nvidia gpu integrated in my laptop.I am totally lost and I fear than more changes to my system result in inusable boot. (I have already problems with my laptop screen resolution, but I think than that maybe depends of not being able to use the nvidia driver so I leave that for another topic). In resume: I have read many things, I am lost with this and I need help from someone that knows more.

I will provide the same commands the person in that thread:

nvidia-settings (Although the window oppens)

ERROR: nvidia-settings could not find the registry key file or the X server is
       not accessible. This file should have been installed along with this
       driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

mhwd -l && mhwd -li && mhwd-kernel -li

> 0000:01:00.0 (0302:10de:1298) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI

> 0000:04:00.2 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

> 0000:00:02.0 (0300:8086:0166) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
         network-r8168            2023.09.12                true            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
   network-broadcom-wl            2018.10.07               false            PCI

Warning: No installed USB configs!
Currently running: 6.1.71-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux61

LANG=C pacman -Ss nvidia | grep instalado

extra/bumblebee 3.2.1-23 [instalado]
extra/egl-wayland 2:1.1.13-1 [instalado]
extra/libvdpau 1.5-2 [instalado]
extra/libxnvctrl-390xx 390.157-4 [instalado]
extra/linux61-nvidia-390xx 390.157-83 (linux61-extramodules) [instalado]
extra/mhwd-nvidia 545.29.06-2 [instalado]
extra/mhwd-nvidia-390xx 390.157-9 [instalado]
extra/mhwd-nvidia-470xx 470.223.02-1 [instalado]
extra/nvidia-390xx-utils 390.157-9 [instalado]
extra/nvidia-settings 545.29.06-1 [instalado]
extra/xf86-video-nouveau 1.0.17-2 (xorg-drivers) [instalado]
multilib/lib32-libvdpau 1.5-2 [instalado]

inxi -Fazy

  Kernel: 6.1.71-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=47684a74-b004-49ee-bdac-afaa4569790f rw nouveau.modeset=0 quiet
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: ASUSTeK product: X550CC v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X550CC v: 1.0 serial: <superuser required>
    part-nu: ASUS-NotebookSKU uuid: <superuser required>
    UEFI: American Megatrends v: X550CC.300 date: 03/24/2014
  ID-1: BAT0 charge: 56.0 Wh (98.8%) condition: 56.7/63.9 Wh (88.8%)
    volts: 14.5 min: 14.5 model: ASUSTeK X550A26 type: Li-ion serial: N/A
    status: not charging cycles: 638
  Info: model: Intel Core i7-3537U bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 802 high: 815 min/max: 800/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 815 2: 798 3: 800 4: 798
    bogomips: 19960
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1,VGA-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:0166 class-ID: 0300
  Device-2: NVIDIA GK208M [GeForce GT 720M] vendor: ASUSTeK driver: N/A
    alternate: nouveau, nvidia_drm, nvidia non-free: series: 470.xx+
    status: legacy-active (EOL~2024-09-xx) arch: Fermi 2 code: GF119/GK208
    process: TSMC 28nm built: 2010-2016 pcie: speed: Unknown lanes: 63
    link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.0 chip-ID: 10de:1298
    class-ID: 0302
  Device-3: Chicony USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.3:3 chip-ID: 04f2:b40a
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.10 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: intel unloaded: nvidia dri: i965 gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: LVDS-1 mapped: LVDS1 pos: primary model: AU Optronics 0x45ec
    serial: <filter> built: 2010 res: 960x540 hz: 60 dpi: 72 gamma: 1.2
    size: 340x190mm (13.39x7.48") diag: 394mm (15.5") ratio: 16:9
    modes: 1366x768
  Monitor-2: VGA-1 mapped: VGA1 model: Idek Iiyama PLT2250MTS
    serial: <filter> built: 2010 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 480x270mm (18.9x10.63") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: intel crocus platforms: device: 0 drv: crocus
    device: 1 drv: swrast gbm: drv: crocus surfaceless: drv: crocus x11:
    drv: crocus inactive: wayland
  API: OpenGL v: 4.5 compat-v: 4.2 vendor: intel mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
    device-ID: 8086:0166 memory: 1.46 GiB unified: yes
  API: Vulkan v: 1.3.274 layers: 4 device: 0 type: integrated-gpu name: Intel
    HD Graphics 4000 (IVB GT2) driver: mesa intel v: 23.3.3-manjaro1.1
    device-ID: 8086:0166 surfaces: xcb,xlib
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK 7
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.1
    chip-ID: 10de:0e0f class-ID: 0403
  API: ALSA v: k6.1.71-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: active tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.0 status: off tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Lite-On
    driver: ath9k v: kernel modules: wl pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 168c:0032 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8168 v: 8.052.01-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.2 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp4s0f2 state: down mac: <filter>
  Local Storage: total: 1.8 TiB used: 403.14 GiB (21.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT480BX500SSD1
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: R022 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: HD154UI size: 1.36 TiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 12 Mb/s
    lanes: 1 mode: 1.1 tech: N/A serial: <filter> scheme: MBR
  ID-1: / raw-size: 39.06 GiB size: 38.15 GiB (97.67%) used: 34.49 GiB (90.4%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4
  ID-3: /home raw-size: 401.86 GiB size: 394.48 GiB (98.16%)
    used: 367.72 GiB (93.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 5.71 GiB used: 952.5 MiB (16.3%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 59.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 2800
  Memory: total: 6 GiB available: 5.68 GiB used: 4.03 GiB (70.9%)
  Processes: 318 Power: uptime: 2d 1m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform
    avail: shutdown,reboot,suspend,test_resume image: 2.26 GiB
    daemons: upowerd,xfce4-power-manager Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 2235 libs: 506 tools: pamac,yay pm: flatpak
    pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 alt: 9 Shell: Bash v: 5.2.21
    running-in: gnome-terminal inxi: 3.3.32

for x in $(ls /etc/X11/xorg.conf.d/); do echo -e “—$x—\n\n $(cat /etc/X11/xorg.conf.d/$x)\n\n”; done


 # Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "es"
        Option "XkbModel" "pc105"


## Generated by mhwd - Manjaro Hardware Detection
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod" "sna"
	Option      "DRI"    "true"
Section "DRI"
        Group  "video"
        Mode   0666
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"


bash: prime-run: orden no encontrada

sudo pacman -S prime-run

error: no se ha encontrado el paquete: prime-run

Then the chat is very technical and I don’t follow it well.

Thank you!

install 470xx

nvidia-470xx-utils y nvidia-390xx-utils están en conflicto (nvidia-libgl). ¿Quitar nvidia-390xx-utils? 
error: no se pudo preparar la operación (no se pudo satisfacer las dependencias)
:: quitando nvidia-390xx-utils se rompe la dependencia con «nvidia-utils=390.157», necesaria para el paquete linux61-nvidia-390xx

That means the two packages are in conflict.

Did you read the final part of the thread I linked? Seems to talk about that.

Do you know if it is safe to remove 390xx and install 470xx?

Edit: OK. I installed the package and the output of nvidia-smi is the same:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Edit2: Oh, in fact the “Ss nvidia” indicated that 470xx was already installed (?)


This is the latest

and this Site say 390xx is the latest

GeForce GT 720M 1140 1019 999F

I don’t understand the links you posted.

So I install again the 390xx? I install the nvidia 418?

Edit. So I removed 470xx and installed again 390xx… I have no clue of what to do now.

The nvidia release notes lists your card only at the 390xx and 418xx driver.

Since there seams no 418 in the repos, you should install the 390xx, to have a supported configuration.

And 390 is not supported by prime … but does work with bumblebee

This will reinstall the correct profile:

sudo mhwd -f- i pci video-hybrid-intel-nvidia-390xx-bumblebee

So prime-run wont work.
You should use primusrun or optirun

These are example runs of glxinfo, the first should return intel and the others the nvidia:

glxinfo | grep 'renderer string'
optirun glxinfo | grep 'renderer string'
primusrun glxinfo | grep 'renderer string'

This is because its an old device.
So its stuck using an old driver and an old method for gpu switching.

If you want to know more about bumblebee heres the Archwiki:

First time since I use this laptop that nvidia-smi doesn’t respond with “nvidia is not installed”.

Anyway when I run the first command:

optirun glxgears -info
[ 283.444526] [ERROR]You’ve no permission to communicate with the Bumblebee daemon. Try adding yourself to the ‘bumblebee’ group
[ 283.444551] [ERROR]Could not connect to bumblebee daemon - is it running?

If I use sudo:
sudo optirun glxgears -info
[ 267.745510] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[ 267.745538] [ERROR]Aborting because fallback start is disabled.

Does this mean you followed the above directions for reinstalling the bumblebee profile and it succeeded?

Have you rebooted in between?

I’m not going to go dissecting the old mhwd profile to see if it is missing this part, but bumblebee also requires, quoting the Archwiki,

Meaning (using your forum name as if it were your username) for you:

sudo gpasswd -a jakeukalane bumblebee
systemctl enable bumblebeed

And reboot.
Then check the operation of primusrun/optirun.

primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) No devices detected.

Anyway, at least the driver is installed. I’ll mark as solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.