Nvidia Driver not being loaded on Fresh installed Manjaro Plasma

Hi everyone! I’m a manjaro newbie and here’s my situation:

I’ve already installed Manjaro Plasma successfully, with no video driver problems. But, since i’d just replaced Distros from Linux Mint (the “replace partition” option of the installer), it didn’t mount the /usr and /home as i intended, so i tried reinstalling Manjaro and manually configuring the mounting paths to avoid terminal commands mess.

On this second attempt, everything went fine but my display resolution was capped to 1024x768 (i have a 1080p monitor). I’ve found that my system already has the respective nvidia driver for my GPU (550.78), but some how my system is not loading it. I’ve tried doing the installation process again but the problem persists.

Here’s what i’ve already tried:
Force reinstall the driver - Result:

> sudo mhwd -f -i pci video-nvidia

Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 multilib downloading...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: eglexternalplatform will be installed before its nvidia-utils dependency

Packages (7) egl-wayland-2:1.1.13-1  eglexternalplatform-1.1-2  lib32-nvidia-utils-550.78-1  libxnvctrl-550.78-1  linux69-nvidia-550.78-1  nvidia-settings-550.78-1  nvidia-utils-550.78-1

Total Installed Size:  848,75 MiB

:: Proceed with installation? [Y/n] 
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
error: failed to commit transaction (conflicting files)
eglexternalplatform: /usr/include/EGL/eglexternalplatform.h exists in filesystem
eglexternalplatform: /usr/include/EGL/eglexternalplatformversion.h exists in filesystem
eglexternalplatform: /usr/share/licenses/eglexternalplatform/COPYING exists in filesystem
eglexternalplatform: /usr/share/pkgconfig/eglexternalplatform.pc exists in filesystem
egl-wayland: /usr/lib/libnvidia-egl-wayland.so exists in filesystem
*...lot of "exists in filesystem"...*
linux69-nvidia: /usr/lib/modules/6.9.0-1-MANJARO/extramodules/nvidia-uvm.ko.xz exists in filesystem
linux69-nvidia: /usr/lib/modules/6.9.0-1-MANJARO/extramodules/nvidia.ko.xz exists in filesystem
linux69-nvidia: /usr/share/licenses/linux69-nvidia/LICENSE exists in filesystem
Errors occurred, no packages were upgraded.
Error: pacman failed!
Error: script failed!

Removing the video-linux driver - result:
PS.: Somehow, in the latest installation, video-linux driver doesn’t seem to be installed, i guess because i selected to use proprietary drivers boot (i got distracted in the second installation attempt and it may have gone to the free/open driver)

Removing video-linux...
Sourcing /etc/mhwd-x86_64.conf 
Has lib32 support: trueSourcing /var/lib/mhwd/local/pci/video-linux/MHWDCONFIG
Processing classid: 0300 
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0380
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies):: removing libva-mesa-driver breaks dependency 'libva-mesa-driver' required by lib32-libva-mesa-driver
Error: pacman failed!
Error: script failed!

Since everybody asks for this on this topic, here’s my
inxi -Fazy and mhwd -l:

inxi -Fazy:

> inxi -Fazy                                                                                     
  Kernel: 6.9.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9-x86_64
    root=UUID=cfcc37cf-dc45-49bf-a3f3-18f13d46230a rw quiet splash
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop System: Gigabyte product: B450M DS3H v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: F61c
    date: 05/10/2021
  Info: model: AMD Ryzen 5 1600X bits: 64 type: MT MCP arch: Zen level: v3
    note: check built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1
    stepping: 1 microcode: 0x8001138
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 2355 high: 3600 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 2200
    3: 2200 4: 2200 5: 2200 6: 2200 7: 2894 8: 2200 9: 3600 10: 2200 11: 1973
    12: 2200 bogomips: 86268
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; STIBP:
    disabled; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: eVga.com. driver: N/A
    alternate: nouveau non-free: 545.xx+ status: current (as of 2024-04;
    EOL~2026-12-xx) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 07:00.0 chip-ID: 10de:1c03 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
    alternate: fbdev,nv,vesa gpu: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.63x7.99")
    s-diag: 338mm (13.3") monitors: <missing: xrandr>
  Monitor-1: Unknown-1 size-res: N/A modes: 1024x768
  API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: swrast x11: drv: swrast inactive: wayland
  API: OpenGL v: 4.5 vendor: mesa v: 24.0.6-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: llvmpipe (LLVM 17.0.6 256 bits)
    device-ID: ffffffff:ffffffff memory: 15.2 GiB unified: yes
  API: Vulkan Message: No Vulkan data available.
  Device-1: NVIDIA GP106 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 07:00.1 chip-ID: 10de:10f1
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1:2
    chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
  API: ALSA v: k6.9.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:4
    chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.81 TiB used: 10.59 GiB (0.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: SBI02102 temp: 50.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Patriot model: Burst size: 447.13 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 61.2 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-21WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Generic model: Flash Disk
    size: 7.5 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter> fw-rev: 8.07
    scheme: MBR
  ID-1: / raw-size: 40 GiB size: 39.08 GiB (97.69%) used: 1.07 GiB (2.7%)
    fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-3: /home raw-size: 283.47 GiB size: 277.96 GiB (98.06%)
    used: 240.3 MiB (0.1%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /usr raw-size: 140 GiB size: 136.74 GiB (97.67%)
    used: 9.29 GiB (6.8%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2
  System Temperatures: cpu: 43.9 C mobo: 34.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.56 GiB used: 2.4 GiB (15.4%)
  Processes: 306 Power: uptime: 1m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.18 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1137 libs: 320 tools: pamac pm: flatpak pkgs: 0
    Compilers: N/A Shell: Zsh v: 5.9 default: Bash v: 5.2.26 running-in: konsole
    inxi: 3.3.34

mhwd -l:

>mhwd -l                                                                                        ✔ 

0000:07:00.0 (0300:10de:1c03) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2024.05.03               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:05:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

Also, here’s what nvidia-settings gives me:

> sudo nvidia-settings

ERROR: NVIDIA driver is not loaded

(nvidia-settings:2952): GLib-GObject-CRITICAL **: 19:14:14.554: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:2952): CRITICAL **: 19:14:14.556: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

ERROR: nvidia-settings could not find the registry key file or the X server is not accessible. This file
       should have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will
       continue to work, but values cannot be prepopulated or validated, and will not be listed in the help
       text. Please see the README for possible values and descriptions.

PS.: My CPU doesn’t have a built-in GPU, so there’s some driver working, i’m currently using this system/machine to write this topic, the only problem is the capped resolution and refresh rate.

Judgning from the - conflicting files messages - it would seem you have tried to install nvidia using the installer provided from nvidia website.

Is that a correct assessment?

Actually, i didn’t. First, i thought i wouldn’t need to install the driver. Since my CPU doesn’t have a Built-in GPU, if the system shows any image, i assume there’s a compatible driver in it. What i tried to do was reinstall the proprietary drivers using the command sudo mhwd -i pci video-nvidia and then sudo mhwd -f -i pci video-nvidia, both with the “file exists in filesystem” message. Also, at the first installation attempt, i didn’t need to install anything, the display configs and GPU were fine.

Multiple ‘file exists…’
Its because of the preserved /usr from some other install.

You will need to manually overwrite those paths or delete them, etc.
You will have untold numbers of these kinds of problems due to your approach of retaining /usr.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.