Nvidia Driver Installation Problem

Hi all,

I had to format my laptop; now I am not able to install Nvidia as Prime. One of friends in this forum had helped me through the installation process and I was counting on that I was planning to follow the instructions in that topic. But I couldn’t find it. So I tried to do it alone. I dealed with a few errors but I am stuck here:

ERROR: Unable to load the kernel module ‘nvidia-uvm.ko’. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if another driver such as nouveau, is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA GPU(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

Please see the log entries “Kernel module load error” and “Kernel messages” at the end of the file “/var/log/nvidia-installer.log” for more information.

And this is the log file:

Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.
**-> Kernel module load error: No such file or directory**
ERROR: The nvidia-uvm kernel module failed to load. This kernel module is required for the proper operation of CUDA. If you do not need to use CUDA, you can try to install this driver package again with the '--no-unified-memory' option.
-> Kernel messages:
[   18.211577] audit: type=1334 audit(1602523699.348:56): prog-id=11 op=LOAD
[   19.000187] fuse: init (API version 7.31)
[   34.454486] kauditd_printk_skb: 4 callbacks suppressed
[   34.454487] audit: type=1100 audit(1602523715.591:61): pid=1060 uid=1000 auid=1000 ses=1 subj==unconfined msg='op=PAM:authentication grantors=pam_faillock,pam_permit,pam_faillock acct="stockfish" exe="/usr/bin/sudo" hostname=StockfishPC addr=? terminal=/dev/tty1 res=success'
[   34.456910] audit: type=1101 audit(1602523715.591:62): pid=1060 uid=1000 auid=1000 ses=1 subj==unconfined msg='op=PAM:accounting grantors=pam_permit,pam_time acct="stockfish" exe="/usr/bin/sudo" hostname=StockfishPC addr=? terminal=/dev/tty1 res=success'
[   34.457085] audit: type=1110 audit(1602523715.591:63): pid=1060 uid=0 auid=1000 ses=1 subj==unconfined msg='op=PAM:setcred grantors=pam_faillock,pam_permit,pam_faillock acct="root" exe="/usr/bin/sudo" hostname=StockfishPC addr=? terminal=/dev/tty1 res=success'
[   34.458620] audit: type=1105 audit(1602523715.594:64): pid=1060 uid=0 auid=1000 ses=1 subj==unconfined msg='op=PAM:session_open grantors=pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/sudo" hostname=StockfishPC addr=? terminal=/dev/tty1 res=success'
[   36.772660] audit: type=1131 audit(1602523717.908:65): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   36.884035] audit: type=1334 audit(1602523718.021:66): prog-id=10 op=UNLOAD
[   36.884047] audit: type=1334 audit(1602523718.021:67): prog-id=9 op=UNLOAD
[   83.748162] VFIO - User Level meta-driver version: 0.3
[   83.763300] IPMI message handler: version 39.2
[   83.765386] ipmi device interface
[   83.772703] nvidia: loading out-of-tree module taints kernel.
[   83.772711] nvidia: module license 'NVIDIA' taints kernel.
[   83.772712] Disabling lock debugging due to kernel taint
[   83.778031] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[   83.793254] nvidia-nvlink: Nvlink Core is being initialized, major device number 511
[   83.793654] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[   83.894047] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  450.80.02  Wed Sep 23 01:13:39 UTC 2020
[   83.896907] nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.
[   83.897140] nvidia_uvm: Unknown symbol set_cpus_allowed_ptr (err -2)
[   83.897174] nvidia_uvm: Unknown symbol mmu_notifier_unregister (err -2)
[   83.897292] nvidia_uvm: Unknown symbol __mmu_notifier_register (err -2)
[  169.949645] logitech-hidpp-device 0003:046D:4054.0003: HID++ 4.5 device connected.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

So, kernel module says, “No such file or directory” Whats that supposed to mean?

And finally, steps I did:

  1. Fresh install

  2. Created a blacklist.conf file containing:

    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
  3. sudo systemctl disable sddm

  4. Restart

  5. account login on black screen. You call it TTY or something :sweat_smile:

  6. cd to Nvidia.run file and sudo sh nvidia.run

  7. Dealed with a few errors

  8. Stucked at final error I mentioned.

Your help is greatly appreciated :slight_smile:

Manjaro has a tool for this. It is called MHWD (Manjaro Hardware Detection).No need to download it from the nvidia website. Here is a manual for the commandline: Configure Graphics Cards - Manjaro

The GUI is called manjaro-settings-manager -> Manjaro Settings

I think I couldn’t explain myself, I already know that. Drivers in the GUİ and the driver from the website is entirely different. I did this twice, It was working flawlessly. I want to use Nvidia alone and completely disable Intel. With GUİ drivers I can’t do that, and they are freezing in games, don’t work.

If you don’t want to use it as prime, then don’t install prime.

Instead of video-hybrid-intel-nvidia-450xx-prime, just install video-nvidia-450xx and intel will not be used.

mhwd -r video-hybrid-intel-nvidia-450xx-prime
mhwd -i pci video-nvidia-450xx

Did you do this?

1 Like

Could you not just install optimus manager or optimus switch and then just switch to nvidia from there? That way it would always run nvidia

I get this:

“error: target not found: linux59-nvidia-450xx”
“Error: pacman failed!”
“Error: script failed!”

What says?

mhwd -l && mhwd -li

If you use iGPU Intel and dGPU Nvidia, then this could be a solution: NVIDIA Optimus - ArchWiki

Oh no. Check the following: Nvidia opencl not working with kernel 5.9 and The end of Nvidia proprietary Drivers on Linux !?! .

Try an older kernel: 5.4 or 5.8.

Ok, I have installed vide-nvidia-450xx. This is current info:

$ glxinfo | grep OpenGL

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® HD Graphics 4600 (HSW GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 20.1.8
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 20.1.8
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.1.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

So I need to completely disable intel. But how?

LoL. I am writing from mobile :slight_smile: After reboot I got a black screen. What now?

Press Ctrl+Alt+F4, log in, and check the logs.

I logged in. How can I check logs?

Check the most recent Xorg log in ~/.local/share/xorg/ or /var/log/. But first check if Xorg is running or not: if pidof Xorg shows anything, then it’s running. By the way, which kernel are you running? If it’s 5.9, then please downgrade to 5.4 or 5.8.

Kernel now 5.8
pidof return is: “913”
This is the log file:

Is it still booting to a black screen? If so, please run

sudo mhwd -r pci video-nvidia-450xx
sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

and reboot.

I got booted. Thank you.
İt didn’t install prime. Now I installed it via system settings.
I rebooted again and no problem.

So, back to the zero point. How can I completely disable Intel GPU? Otherwise, it won’t let NVidia work.

What is going to show the images on the integrated display then? If your BIOS has an option to exclusively use discrete GPU, then you can use that. Otherwise the integrated GPU must be active and the i915 driver must be loaded, and the modesetting (or intel) Xorg driver must be loaded.

Please elaborate.

Ok, I did this 2-3 times in the past with the help of a friend in the forum, I was following the instructions but I can’t find the topic; possibly archived.
Anyway, in those instructions I didn’t use prime or nvidia-440xx. I directly installed the .run file from nvidia website in the black screen. And it worked flawlessly for months. When I applied the code:

glxinfo | grep OpenGL

I would only see NVidia without any intel.
If I knew I wouldn’t be able to install this way again, I wouldn’t format.

With this setup, when I am in game it still uses intel GPU and extremely freezes. How am I sure of it? Because, when it was with NVidia setup, it was pouring like water.

What do you suggest?

You can use prime-run <PROGRAM> to allow a program utilize the nvidia gpu. E.g. prime-run glxinfo | grep "OpenGL vendor" should print “NVIDIA Corporation”.

1 Like

Thank you for your help; I will try it.