Nvidia driver conflict with latest update

Hello.

I am having my first ever issue with Manjaro. It seems there is a system update which I can’t apply due to Nvidia driver conflict.

Here is my update log:

:: Synchronizing package databases...
 core       169.2 KiB  2.75 MiB/s 00:00 [######################################################################] 100%
 extra      2013.0 KiB  9.36 MiB/s 00:00 [######################################################################] 100%
 community  6.2 MiB  9.92 MiB/s 00:01 [######################################################################] 100%
 multilib   194.3 KiB  47.4 MiB/s 00:00 [######################################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: nvidia-450xx-utils and nvidia-390xx-utils are in conflict (nvidia-libgl). Remove nvidia-390xx-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'nvidia-390xx-utils=390.132' required by linux54-nvidia-390xx
:: unable to satisfy dependency 'nvidia-390xx-utils=390.132' required by linux57-nvidia-390xx
:: removing nvidia-390xx-utils breaks dependency 'nvidia-390xx-utils' required by lib32-nvidia-390xx-utils
:: removing nvidia-390xx-utils breaks dependency 'nvidia-390xx-utils=390.132' required by linux58-nvidia-390xx
error installing repo packages

Here is my system info:

β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   rebelCoder@rebelLinuxPC 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   ------------------- 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   OS: Manjaro Linux x86_64 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Host: CW23S 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ            β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Kernel: 5.4.62-1-MANJARO 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Uptime: 13 mins 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Packages: 1312 (pacman) 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Shell: bash 5.0.18 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Resolution: 1920x1080, 2048x1152 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   DE: Plasma 5.19.4 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   WM: KWin 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Theme: Breeze Dark [Plasma], Breath-Dark [GTK2/3] 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Icons: breeze-dark [Plasma], breeze-dark [GTK2/3] 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Terminal: konsole 
                               Terminal Font: Hack 10.5 
                               CPU: Intel i7-4710MQ (8) @ 3.500GHz 
                               GPU: NVIDIA GeForce GTX 765M 
                               GPU: Intel 4th Gen Core Processor 
                               Memory: 2591MiB / 15935MiB 

I have a bumblebee driver and I use primusrun to run some application.
Is there a way to fix this somehow, or do I need to re-install the system?

Thanks!

Take a look at :point_down:

Yep, I have looked and tried all the solutions I found. Same issue arises: I can’t remove/install new driver as something breaks some other dependency.

> Installing video-hybrid-intel-nvidia-450xx-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-450xx-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-390xx-utils breaks dependency 'nvidia-utils' required by cuda
Error: pacman failed!

It seems that this update breaks some systems and I need to reinstall. :thinking:

Try sudo pacman -R cuda before trying to install video-hybrid-intel-nvidia-450xx-prime and reinstall cuda afterwards

yay -R cuda 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing cuda breaks dependency 'cuda' required by local

:rofl:

Alright. I guess at this stage it is easier to re-install as I don’t have time to hack around all day :frowning: interesting enough that I don’t see anyone else having this issue.

Makes me wonder what local is, cant find a package named local in the repos or AUR.
I dont know maybe somebody else can have a look

Why using AUR helpers for official packages? I know is possible, but … we have pacman and pamac.

Edit:
In addition, have you checked if your GPU is supported by 450.66 driver you want to install?
https://download.nvidia.com/XFree86/Linux-x86_64/450.66/README/supportedchips.html

Not even the 435 supports that GPU.
https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/supportedchips.html

neither 430
https://download.nvidia.com/XFree86/Linux-x86_64/430.64/README/supportedchips.html

Here is where the support stops
https://download.nvidia.com/XFree86/Linux-x86_64/418.113/README/supportedchips.html

So, you will have to probably use
video-hybrid-intel-nvidia-418xx-bumblebee

1 Like

Having the same issue here. The system is pretty old so I’m concerned about doing any updates to the display drivers. Plus, it’s a remote machine that I don’t have physical access to so if anything goes wrong I’m screwed…

I did a re-install. So only /root/ partition got replaced. Did not lose any files or config. Re-installing - 5 mins. F**g around with drivers…hours? And this made me move away from Bumblebee driver and have a better driver, using optimus-manager as a result.

1 Like