[Nvidia] Deprecation of 340xx driver series

Interesting. It’s a regression though (and it could even just affect newer drivers).

The last official kernel that nvidia supports is 5.4, but there are patches (which manjaro/AUR ships with) for up to 5.8.
5.9-rc1 was just released last week… So there’s still time for somebody to come up with a solution.

1 Like

Are you thinking of 450?
There doesn’t seem to be a driver version 350.
I’ve not heard of it before, so I googled ‘nvidia linux driver 350’ – nothing there.

Here you can see the list of products supported by the 450 driver:
https://www.nvidia.com/Download/driverResults.aspx/160555/en-us
My Quadro FX is not there, it still needs version 340.

Is there a guide for patching (for 340)?
I don’t write C code (only python), and can understand only a little of it.
Would need a beginners guide …

https://github.com/mirh/packages-legacy/tree/master/nvidia340
https://aur.archlinux.org/pkgbase/nvidia-340xx

1 Like

I reported the issue (https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/-/issues/547), but they don’t seem very active there…

Right… Well, if you know the regression extremes, you can try to bisect the problem.
https://wiki.archlinux.org/index.php/Bisecting_bugs_with_Git

What is the decision regarding 340xx driver? My dad uses old PC that still runs fine, and we see no reason to change it and it uses 340xx Nvidia drivers.
If there will be no driver updates with at least 5.4 LTS kernel, I will have to switch to another distro :frowning: on this PC.

5.7 became EOL (which this PC is still running), 5.8 should at least have 340xx support but it will become EOL at some point, so I expect that the drivers will be maintained for the 5.4 and lower LTS kernels. This would mean, driver should be recognized as the hardware using it is still being used and for many purposes it is working fine.

I already thought 5.8 doesn’t have 340xx drivers, because after adding 5.8 kernel system borked out and had to restore it from backup. On the other hand, changing the kernel wasn’t helping so this was probably some different issue. Probably I will switch to 5.4. Or maybe it has something to do with the fact that the system uses Deepin, so maybe there are no DKMs for 5.8 or something else is missing? But that is off topic. The main thing is, 340xx drivers are still very needed for some PCs or laptops.

NVidia has stopped developing all drivers less than 450:
https://forums.developer.nvidia.com/t/current-graphics-driver-releases/28500

Here you can see which cards the 450 driver supports:
https://www.nvidia.com/Download/driverResults.aspx/163238/en-us

But the problem is deeper than just phasing out old drivers.
https://forum.manjaro.org/t/the-end-of-nvidia-proprietary-drivers-on-linux/15325/
The root of the problem is the same: GPL licence mixing with closed source binaries.
That link is at the top of this topic, but I didn’t notice it until now.

1 Like

NVidia 340xx: Problems with update 09/08/2020 and workaround

Today’s upgrades wouldn’t work: the cuda package insisted on nvidia-450xx, and there were a number of conflicts.

Workaround:
I added IgnorePkg = cuda to /etc/pacman.conf , pinning the package to its current version. Thereafter things ran smoothly, but of course that package is now frozen in time.

I’m not exactly happy about nvidia-340xx being deprecated, and I kind of do see more problems of this kind looming on the horizon.

Very much so. My GeForce 210 is still running like it was new, despite its 11 years. It bugs me to have to change and fiddle around with adaptors to get my VGA screen to plug into whatever new hardware I buy.

I am not being able to upgrade my Manjaro anymore … when I try to do a

pamac update … I receive in return:
Erro: Falha ao preparar transação:
não foi possível satisfazer as dependências:

  • Incapaz de satisfazer dependência ‘nvidia-340xx-utils=340.108’ requerida por linux54-nvidia-340xx
  • Incapaz de satisfazer dependência ‘nvidia-340xx-utils=340.108’ requerida por linux57-nvidia-340xx
    and I am not able to upgrade anymore
    Is this a collateral effect of this decision to deprecate the 340xx series ? Do they realized that they simply could stuck a lot of people’s machines with this decision ?
    This is incredible !!!
    Is there a way out of this ? Should I change my computer ? Or should I just simply not upgrade anymore for the rest of my life ?

If you read the previous messages more carefully, you will realize that it is because of nVidia not keeping their Linux drivers up-to-date. It is not the fault of Manjaro people.

Also, everyone is forgetting about the nouveau driver, which you can use instead. Perhaps you don’t consider it because it’s not perfect. But if nVidia stops developing drivers for Linux, then one way out of the problem is for Linux people to support improvement of nouveau.

I understand that nVidia not supporting their own hardware is the source of all of this … but I believe in one sense there is at least some fault of Manjaro people here … they should stop presenting me upgrades to newer kernels, as newer kernels, in principle are not compatible anymore with my hardware, but they should not stop allowing me doing ALL KINDS of upgrade. Because right now this is exactly what is happening. I cannot upgrade at all. I cannot upgrade AT ALL. In my point of view, this is a failure in the package manager, or at least in the rules of dependency, which are blocking me.There should be a way in which I should decline the upgrade of the kernel packages and upgrade the rest of the packages … but this is not working.

@gudwin It’s very strange. I also use nvidia340 with kernels 54 and 57. I updated yesterday, everything works fine.

I feel your pain, because, until my T61 quit, I was running 340xx. But, Manjaro is a rolling distro, and what is nice about it is that you get new packages all the time without a periodic install. Maintainers of rolling distros generally cannot backport much, if anything, and for you to attempt a partial upgrade would be unsupported.

If you really want to run old, proprietary, hardware, I generally recommend Debian stable, with non-free packages. But for real help, you will need to go on their forums. And, of course, you will not get the updated packages you are used to getting here.

@napcok can you confirm that you upgraded linux54-nvidia-340xx to version 340.108-62 and linux57-nvidia-340xx to 340.108-26 with success ? Because right now I have linux54-nvidia-340xx in version 340.108-60 and linux57-nvidia-340xx in version 340.108-24, and this is the situation where the problem is appearing. Both of them are already 340.108 and I have last upgraded two days ago. Have you already tried to upgrade today ? Are you already in these last versions ?
For me, there is a problem in the upgrade dependencies … I just can’t realize what it is …

Upgraded yesterday:

napcok@mabox ~ $ pacman -Q | grep 340xx
lib32-nvidia-340xx-utils 340.108-1
linux54-nvidia-340xx 340.108-62
linux57-nvidia-340xx 340.108-26
mhwd-nvidia-340xx 340.108-1
nvidia-340xx-utils 340.108-1
1 Like

Dear @napcok, thanks for your reply ! Success … I solved the mystery ! And solved also the problem. Because you were able to successfully upgrade, I investigated and discovered that the problem was that I had installed also cuda. And cuda was the problem. For some unknown reason, cuda was creating a conflict which was preventing the upgrade of nvidia-340xx-utils and then, of linux54-nvidia-340xx. I had to uninstall cuda, upgrade and install cuda again after that. I don’t know exactly why … but now things are working again. Many thanks !

1 Like

It’s very easy, and compatible, to put your system on an LTS kernel (5.4) and ignore the later kernels. (I have always done this.) Usually LTS are 5 minor versions apart, so I expect 5.9 will be the next one.

Usually i wait until the next LTS is properly stable, then switch to it, but this time 5.9 will not have the nvidia340 driver, so I will stay on 5.4 as long as I can.

Eventually, X-org will upgrade to a point where the nvidia340 driver cannot work with it. Holding back updates of X might not be as simple as staying on an older kernel.
If it’s not practical to do that, I will try nouveau again, and hope that enough of its problems have been fixed by then.

If nouveau does not work well enough then, it will be time to buy new hardware.
I got my Quadro card very cheap, 2nd hand, so it doesn’t bother me.

Whether getting a completely new system or just replacing the video card, I will be inclined to get an AMD gpu. I’ve heard that nVidia has the best graphics in some ways, but I don’t play 3D games, and any old card seems to be adequate for watching movies.
(I also have a 9-year-old laptop with AMD E350 integrated graphics, and it plays 1080p videos fine.)

1 Like

This is my first post, just registered for this Nvidia issue. I upgraded a few days ago. Actually had to force it to update. I probably should have looked closer as to why it didn’t update normally. Now I see it is likely due to this Nvidia. I have a Sony Vaio with Intel i5 M520 @2.40Ghz with Nvidia GeForce GT 330M. The driver for Nvidia is this 340.108 on Kernal 5.7.19.2.

Before this everything was working perfectly. Having used Ubuntu based systems for years I switched to Manjaro because those didn’t allow the FN brightness keys to work. Manjaro worked right off the bat and now unfortunately it has come back.

The FN volume keys work. For brightness, the FN - key does not work it just goes to a black screen. Pressing the FN + key brings it back to full brightness. I have to open the deepin control panel and change the brightness to a lower settings on the slider.

Im also having an issue with the kwin compositing feature going away after a reboot. If I remove the nvidia driver and just use the video-linux, nouveau? driver everything works.

What a shame that this wont be supported anymore since I rather prefer using an Arch based system over ubuntu/debian. Manjaro just worked without any tweaks.

If I could just get the FN brightness - key to work I would be happy.