Nvidia / Color correction

Why when i change color correction, and then if i reboot the pc the card graphic + screen not load my last updates

any idea to fixe this issue ??

Open nvidia-settings from terminal with sudo and save the changes to the xorg config file, which should be located at /etc/X11/mhwd.d/nvidia.conf on a normal Nvidia setup on Manjaro.

1 Like

sudo nvidia-settings

i get this error

(nvidia-settings:132861): GLib-GObject-CRITICAL **: 11:02:13.292: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

Is that the only message? If so it’s the same as me, but nvidia-settings opens and I’m able to make whatever changes I need, you should be able to too.

yes, hope after reboot nvidia should keep my update

You will have this kind of message most of the time you open a GTK app from terminal. This is expected.

Why don’t you try, see, and THEN reply?

after reboot i open nvidia settings i found default settings, so my last update not stored :frowning: !!

to give more details about my version linux:

Linux kamal-20hjs1c700 5.18.16-1-MANJARO #1 SMP PREEMPT_DYNAMIC Wed Aug 3 11:18:52 UTC 2022 x86_64 GNU/Linux

A quick google search shows it is a known issue since at least 10 years. linux nvidia-settings color correction doesn't save - Google Suche
You may have luck saving the settings locally, verifying it saved properly, and maybe add a “startup program” to load your local settings with nvidia-settings command.

I already use tweak to startup nvidia-settings when i start pc

To start it, or to load the local config?

nvidia-settings --help

-l, --load-config-only
      Load the configuration file, send the values specified therein to the X server, and exit.  This mode of operation is useful to place in your xinitrc file, for example.

and you’re sure the settings you want applied are properly saved to the local config?

Verify all, and also test manually if it works, when you use nvidia-settings to load the config manually, does it work? If it doesn’t I’m out of idea, and you may have to adjust settings on reboot all the time.

//EDIT: did a last google for you [SOLVED] Nvidia Color Correction Settings - Linux Mint Forums try and report, probably need manual edit to the Xorg config as I don’t see the box to untick in Nvidia Settings.

on this link he said :
Run nvidia settings as root and try unticking ‘include x display names in configuration file’ when you make changes.

i do that

then reboot pc and nothing saved :frowning:

Then I’m out of ideas sorry.

no problem and thank u for ur time

I use colord + colord-kde

cannot understand you

sorry bad english


colord+colord-kde

reads the monitor data “edid” and creates an icc for the correct setting of the monitor. The monitor must of course be capable of this.
I have uninstalled Kgamma. It does not harmonise. I don’t think Kgamma and nvidia-settings harmonise either.

DeepL Translate

Easy to fix:

Open System Settings:
and under Workspace>Startup and Shutdown>Autostart
click on Add>Add Application
then click on Settings>nvidia x server settings

then click on Properties from the nvidia x server settings>Application

and under Commands you copy this:

/usr/bin/nvidia-settings -l

DONE!

1 Like

there no workspace in system settings so cannot found startup and shutdown option

aname - a
5.18.19-3-MANJARO #1 SMP PREEMPT_DYNAMIC Tue Aug 23 15:56:13 UTC 2022 x86_64 GNU/Linux

Search for “auto” and it should be listed.

I’m sorry but if the Workspace section is missing from System Settings then you’ve got a broken system and that’s a major problem beyond your color correction problem.