Nvidia can't change power state from D3cold to D0 (config space inaccessible)

Hi everyone,

When I reboot Manjaro sometimes (not always) I get this message: nvidia can’t change power state from D3cold to D0 (config space inaccessible)

I have to power off and on a couple of times before I’m able to start the system.

I have a Dell XPS15 9560 with Nvidia GTX 1050 and Intel 630 HD Graphics and I have “video-hybrid-intel-nvidia-450xx-prime” driver.

What should I do?
Thanks for taking the time!

Hello,

This seems to have been discussed on Nvidia forum


But i still can’t make much of it.
Also seem to be mentioned here, since 2019
https://patchwork.kernel.org/project/dri-devel/patch/20191017121901.13699-1-kherbst@redhat.com/

I wonder if with the upcoming to stable of the 455xx driver this issue will not happen…

Thanks Bogdan! I saw that too but couldn’t figure out if there’s a solution or not… it seems it’s not…

Sadly i can’t confirm either way or another, but hopefully someone else using a hybrid intel-nvidia GPUs laptop will pass by with some ideas.
Did all this came out while fixing the overheating, or it still does that too?

No, that was separate from the power thing… it happened right after the installation but I ignored it because I couldn’t find a solution and the power off and start again worked…

Since I’m at the troubleshooting day :slight_smile: do you have any idea what should I do so my mouse connected to an USB port be visible at the login screen? Now I have to unplug and plug the mouse USB port to be visible to the system.

Many thanks for taking the time!

That sounds like a TLP thing. Install tlpui package and disable the power management on that port, or the power saving.

I tried that… I changed USB_AUTOSUSPEND from ON to OFF but still can’t see the mouse at startup…

Is it a USB3 port? Change to a USB2 one.