Nvidia 535 driver: freezes when launching games

Using nonstable Manjaro, after latest Nvidia driver update 535.54.3-1 getting total freezes when launching a game.

It doesn’t matter, if it’s Steam game or i launch some games from Lutris.
Tried reinstalling drivers, removing and reinstalling drivers, switching between X11 and Wayland with no luck.

One of journalctl log right after i launch Race the sun game from Steam. log/8.txt at main · keturidu/log · GitHub

And it even won’t start. Stellaris launches but hard crashes while loading the game. Some games will launch, but i never no how long they will work it seems random crashes.

Nondemanding Baldur’s Gate EE launches without problem and recognizes Nvidia card+driver.

Also, when getting freeze at first the mouse cursor is moving, then it also dies. Alt+F4 Ctrl+Alt+Esc Ctrl+Alt+F6 or any other keyboard combination doesn’t work at that moment. Only one time i could press power button ant log out window showed. After i press shut down button the system frozen.

prime-run glxgears works without problem. Steam also recognizes Nvidia.

sysinfo log/sysinfo at main · keturidu/log · GitHub

  Kernel: 6.3.8-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.3-x86_64
    root=UUID=d58bf104-f3d0-48a2-8d0f-6c6a70cd8538 rw quiet loglevel=3
    apparmor=1 security=apparmor udev.log_level=3 systemd.show_status=false
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.10 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82L9 v: IdeaPad 5 Pro 16IHU6
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 5 Pro 16IHU6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: WIN serial: <superuser required>
    UEFI: LENOVO v: GRCN26WW date: 04/21/2023
  ID-1: BAT0 charge: 66.3 Wh (97.6%) condition: 67.9/75.0 Wh (90.6%)
    volts: 17.0 min: 15.4 model: SMP L20M4PE1 type: Li-ion serial: <filter>
    status: not charging cycles: 108
  System RAM: available: 15.41 GiB used: 6.55 GiB (42.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 11th Gen Intel Core i5-11300H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xAA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 2965 high: 3100 min/max: 400/4400 scaling:
    driver: intel_pstate governor: performance cores: 1: 3100 2: 2505 3: 3100
    4: 2621 5: 3100 6: 3100 7: 3100 8: 3100 bogomips: 49784
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: nvidia
    v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-05) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1f97 class-ID: 0302
  Device-3: IMC Networks Integrated Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:3 chip-ID: 13d3:56fb
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau alternate: nv,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
    s-diag: 798mm (31.43")
  Monitor-1: eDP-1 model-id: CSO 0x1602 built: 2020 res: 2560x1600 hz: 60
    dpi: 189 gamma: 1.2 size: 344x215mm (13.54x8.46") diag: 406mm (16")
    ratio: 16:10 modes: 2560x1600
  API: OpenGL v: 4.6 Mesa 23.1.2 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct-render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  API: ALSA v: k6.3.8-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.4 TiB used: 761.07 GiB (53.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lexar model: SSD NM760 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: V0922A0 temp: 33.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Realtek model: RTL9210 NVME
    size: 476.94 GiB block-size: physical: 2048 B logical: 512 B type: USB
    rev: 3.2 spd: 10 Gb/s lanes: 1 mode: 3.2 gen-2x1 tech: SSD serial: <filter>
    fw-rev: 1.00 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 953.57 GiB size: 937.54 GiB (98.32%)
    used: 460.73 GiB (49.1%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: d58bf104-f3d0-48a2-8d0f-6c6a70cd8538
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 16.3 MiB (5.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: FA52-F81D
  ID-3: /run/media/keturidu/games raw-size: 476.94 GiB
    size: 468.38 GiB (98.21%) used: 300.32 GiB (64.1%) fs: ext4 dev: /dev/sda1
    maj-min: 8:1 label: games uuid: 471e5c9a-b939-4eaf-985f-4cb27800f768
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 32 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Device-1: 2-4:2 info: Realtek RTL9210 M.2 NVME Adapter type: mass storage
    driver: uas interfaces: 1 rev: 3.2 speed: 10 Gb/s (1.16 GiB/s) lanes: 1
    mode: 3.2 gen-2x1 power: 896mA chip-ID: 0bda:9210 class-ID: 0806
    serial: <filter>
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-2:2 info: Lenovo Legion M600 Wireless Gaming Mouse
    type: mouse,keyboard,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 17ef:60e6 class-ID: 0300
  Device-2: 3-7:3 info: IMC Networks Integrated Camera type: video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 500mA chip-ID: 13d3:56fb class-ID: fe01 serial: <filter>
  Device-3: 3-10:4 info: Intel AX201 Bluetooth type: bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 8087:0026 class-ID: e001
  Hub-4: 4-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 265 Uptime: 1h 25m wakeups: 30142 Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: 4010 pm: pacman pkgs: 2002 libs: 516 tools: octopi,pamac,yay
  pm: rpm pkgs: N/A note: see --rpm tools: dnf pm: flatpak pkgs: 0 pm: snap
  pkgs: 6 Shell: Zsh v: 5.9 default: Bash v: 5.2.0 running-in: konsole
  inxi: 3.3.27

Can you also provide

mhwd -l -li

And have you set game launch options? Specifically - to use PRIME?

Assuming you do have a PRIME profile working, we can also test it like:

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'


Steam launches automatically with Nvidia card (it shows Nvidia in info) others i tried with prime-run also.

Now i tried to launch same games (Stellaris, Europa Universalis IV to be precise) and they launched just fine. Just before they won’t launch for several days and this time i did change nothing at all. Just tried another time to get new log after freeze+reboot. Really confused now. Maybe it’s not Nvidia problem, but shortage of virtual memory?

I’m not sure how thats being gathered/displayed … but generally speaking that would not be the case.
You would want to augment the launch options [for each game] like so:

prime-run %command%

(‘%command%’ is a steam variable recognized as the game being launched)

Sorry i was not thinking clear at night. Of course you have to run with prime-run in options, i just forgot how i run games in Steam, never touched that setting in years.

Today i tried to launch again Steam game Race the Sun, this time with prime-run %command% and it froze my system right after i press “play” button. x11 kde plasma, No other apps where launched (except Latte).

At that time i launch the game in my journalctl logs there are some errors:

ERROR: ld.so: object ‘/home/keturidu/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.


I also have external Windows drive to dualboot and there Nvidia works without problems, so it should not be a faulty video card case.

Another update. I tried to start the same game in Wayland and there is different crash behavior.

The game froze, but there were no hard lock, so i managed to monitor logs. I may change Virtual Desktops, may minimize frozen window with alt+tab, alt+f4 closes that window.

Uploaded logs from terminal and from journald log:

p.s. Wayland is unusable at the moment - shutter won’t load, latte won’t load, firefox-nightly also didn’t launch.

Hands off Wayland if you use nvidia ! this is an disfunctional combination and whatever your problem might be it will be impossible to solve by using wayland-nvidia.

Thanks, i’ve seen that Wayland is still learning how to work with Nvidia, Optimus laptops in particular. Just desperate to understand what happened, so am trying all available options.

but till now you gave just useless informations and didn’t response to questions from other members. that’s not the way it goes.

Sorry to hear that, maybe i wasn’t clear enough. I answered to all the cscs questions. mhwd and glxinfo output is in this link: JustPaste.it - Share Text & Images the Easy Way

I also answered about using prime-run %command%. Not sure, what you meant.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text. (use the option “preformatted text”)


It’s in the first post, in the link at the very end of it. I edited the first post to provide the same information in preformatted text.

what did you answered ? you gave no information about the questioned output of the command and this isn’t jeopardy. none of us can predict what you mean or think.
what’s the output of the questioned

glxinfo | grep 'renderer string'

there is no answer till no and btw if you check it then post the output of

glxinfo | grep server

Uff… i don’t understand. Are there no links displayed in my messages for other users?

Pasting same output in brackets here:

mhwd -l -li                                                                                  
> Installed PCI configs:
                 NAME               VERSION          FREEDRIVER           TYPE
    video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
          video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:01:00.0 (0302:10de:1f97) Display controller nVidia Corporation:
                 NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
         video-nvidia            2023.03.23               false            PCI
   video-nvidia-470xx            2023.03.23               false            PCI
          video-linux            2018.05.04                true            PCI

> 0000:00:02.0 (0300:8086:9a49) Display controller Intel Corporation:
                 NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
          video-linux            2018.05.04                true            PCI
    video-modesetting            2020.01.13                true            PCI
           video-vesa            2017.03.12                true            PCI

glxinfo | grep 'renderer string'  

OpenGL renderer string: Mesa Intel(R) Xe Graphics (TGL GT2)

prime-run glxinfo | grep 'renderer string'                               

OpenGL renderer string: NVIDIA GeForce MX450/PCIe/SSE2

glxinfo | grep server                                                                                

server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:

prime-run glxinfo | grep server                                                                     

server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

Ok, i almost killed my machine with dozens of hard resetting, but found out what’s wrong with my setup.

At some point i made steam run with prime-run option. Like “prime-run steam” and it worked just perfect till it doesn’t.

Removed prime-run from Steam load, added prime-run to options in-steam preferences and now everything works as it should.

Yeah that is not recommended.
I recall recently some user who refused that advice because “well I am going to add it to the games so why not?” … it wasnt you was it? :sweat_smile:
Anyhoo … glad it worked out.

Sadly, i managed to read that topic several hours after finding this truth hard way. I laughed when i read that statement: “<…> and i just disagree”.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.