Nvidia (460.39) doesn't load with xanmod kernel (5.10.16 non-rt)


I have to use TCP-BBR if I want anything above 300kb/s for download. so i decided to switch to a custom kernel that has it. I chose “linux-manjaro-xanmod-cacule-uksm” from AUR and installed it using pacaur (because there is a interactive screen for customizing the kernel that pamac can’t handle).

I was aware that normally nvidia doesn’t build or run on linux-rt so I specifically chose a verrsion of xanmod that isn’t said to be rt based on their site. however nvidia simply doesn’t run using optimus-manager to force it and I don’t have acces to nvidia gpu using prime either.

I tried nvidia-dksm-performance and nvidia-beta-dkms that appear to have a rt patch in case that is the problem but neither helped the situation. Also tried using mhwd to choose video-nvidia instead of hybrid but system failed to boot into sddm. nouvea also doesn’t let any app use nvidia.

Any help would be appreciated. :slightly_smiling_face:

1 Like

Try 5.4 LTS first because, officially, 5.10 doesn’t support nVidia…

1 Like

Thanks for the solution.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.