Nvidia 390 not working with kernel 66 on new install?

Here I am with a different Nvidia issue (390 series, old i3 laptop). I reinstalled Manjaro and couldn’t graphically boot past Plymouth: Gave me a black screen. I tried reinstalling the driver from command line (0300) and Manjaro Mhwd guy. I can only graphically boot up to kernel 61.
I know 66 worked before I reinstalled so it’s got to do with the installation.
I think I also tried reinstalling the kernel.

Also I know that there’s no more development on Nvidia 390xx.

 inxi -Gz                                   ░▒▓ ✔ at 15:32:27  ▓▒░
Graphics:
  Device-1: NVIDIA GF119M [GeForce 410M] driver: nvidia v: 390.157
  Device-2: Suyin Sony Visual Communication Camera driver: uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.12 with: Xwayland v: 23.2.6 driver: X:
    loaded: nvidia gpu: nvidia s-res: 1366x768
  API: EGL v: 1.5 drivers: kms_swrast platforms: gbm,x11
  API: OpenGL v: 4.5 compat-v: 4.6.0 vendor: nvidia mesa v: 390.157
    renderer: GeForce 410M/PCIe/SSE2
  API: Vulkan Message: No Vulkan data available.

[will edit the tty startx output into here after a reboot into 66]

Ok I could not output that into a file for some reason.

Hope this is the complete log of the boot attempt into linux66:

[   289.158] (II) LoadModule: "glx"
[   289.159] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   289.161] (II) Module glx: vendor="X.Org Foundation"
[   289.161] 	compiled for 1.21.1.12, module version = 1.0.0
[   289.161] 	ABI class: X.Org Server Extension, version 10.0
[   289.161] (II) LoadModule: "nvidia"
[   289.161] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   289.162] (II) Module nvidia: vendor="NVIDIA Corporation"
[   289.162] 	compiled for 4.0.2, module version = 1.0.0
[   289.162] 	Module class: X.Org Video Driver
[   289.162] (II) NVIDIA dlloader X Driver  390.157  Wed Oct 12 09:21:41 UTC 2022
[   289.162] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   289.162] xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)
[   289.162] (II) systemd-logind: releasing fd for 226:0
[   289.163] (II) Loading sub module "fb"
[   289.163] (II) LoadModule: "fb"
[   289.163] (II) Module "fb" already built-in
[   289.163] (II) Loading sub module "wfb"
[   289.163] (II) LoadModule: "wfb"
[   289.163] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   289.163] (II) Module wfb: vendor="X.Org Foundation"
[   289.163] 	compiled for 1.21.1.12, module version = 1.0.0
[   289.163] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   289.163] (II) Loading sub module "ramdac"
[   289.163] (II) LoadModule: "ramdac"
[   289.163] (II) Module "ramdac" already built-in
[   289.171] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[   289.171] (EE) NVIDIA:     system's kernel log for additional error messages and
[   289.171] (EE) NVIDIA:     consult the NVIDIA README for details.
[   289.171] (EE) No devices detected.
[   289.171] (EE) 
Fatal server error:
[   289.171] (EE) no screens found(EE) 
[   289.171] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   289.171] (EE) Please also check the log file at "/home/mrxsm/.local/share/xorg/Xorg.0.log" for additional information.
[   289.171] (EE) 
[   289.174] (EE) Server terminated with error (1). Closing log file.

With such an older machine, and in fairness, you will probably be better served using kernel 6.1.x, regardless; mainly due to it’s projected longevity. Unless there is some pressing need not to.

2 Likes

I agree. Stick to 6.1 SLTS…

1 Like

Also keep in mind the NVIDIA 390.* legacy driver series is no longer being maintained. Please see Support timeframes for Unix legacy GPU releases for more details.

1 Like

Hm thanks so far. However it was the exact same kernel it was running with before my reinstall of the OS. Will wait for the next kernel update and report back. :hourglass_flowing_sand: