Nvidia 1060 woes

Just cannot get Manjaro to work with nvidia.
Laptop is Dell Inspiron 7577 With Nvidia gtx 1060 card. I installed a fresh latest Manjaro.
I followed all options here “wiki.manjaro-dot-org/index.php/Configure_Graphics_Cards” but nothing helped.
Anyone have an idea how I can get it to work with Nvidia ?

Upon installation I used proprietary drivers option.
The Nvidia settings app showed video-hybrid-intel-nvidia-prime driver.
That didnt work at all.
I then installed the video-nvidia driver.
That didnt help at all.
I test the video card with Heaven Benchmark and I get a measely 7fps.

POPOS and Windows 10 have no problem with the card on the same laptop.

Linux != Windows

There is excellent documentation on NVIDIA - ArchWiki - applies for Manjaro as well.

You will have to be a lot more specific - start with uploading some system info to ix.io - provide the link returned using codefence like below example

inxi -Fc0 | curl -F 'f:1=<-' ix.io
$ inxi -Fc0 | curl -F 'f:1=<-' ix.io

Also: It has a intel HD and the Nvidia cards/drivers installed and the drivers are loaded in the kernel for both. I need to switch from the silly Intel HD to Nvidia, see …

$ lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
	DeviceName:  Onboard IGD
	Subsystem: Dell HD Graphics 630
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1)
	Subsystem: Dell GP106M [GeForce GTX 1060 Mobile]
	Kernel driver in use: nvidia
  Host: inspiron7577 Kernel: 6.1.38-1-MANJARO arch: x86_64 bits: 64
    Desktop: Xfce v: 4.18.1 Distro: Manjaro Linux
  Type: Laptop System: Dell product: Inspiron 7577 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0P9G3M v: A00 serial: <superuser required>
    UEFI-[Legacy]: Dell v: 1.2.0 date: 10/25/2017
  ID-1: BAT0 charge: 52.1 Wh (100.0%) condition: 52.1/56.0 Wh (93.1%)
  Info: quad core model: Intel Core i5-7300HQ bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 2075 min/max: 800/3500 cores: 1: 2500 2: 800 3: 2500
    4: 2500
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia
    v: 535.54.03
  Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting,nvidia
    dri: iris gpu: i915 s-res: 1920x1080 resolution: 1920x1080
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel CM238 HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
  API: ALSA v: k6.1.38-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp59s0 state: down mac: a4:4c:c8:7f:55:f4
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
  IF: wlp60s0 state: up mac: 60:f6:77:1a:e1:a4
  Device-1: Intel Bluetooth wireless interface driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  Local Storage: total: 238.47 GiB used: 12.16 GiB (5.1%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM961 NVMe 256GB
    size: 238.47 GiB
  ID-1: / size: 87 GiB used: 12.16 GiB (14.0%) fs: ext4 dev: /dev/nvme0n1p8
  Alert: No swap data was found.
  System Temperatures: cpu: 44.0 C pch: 43.5 C mobo: 42.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 3717
  Processes: 238 Uptime: 7m Memory: total: 8 GiB note: est.
  available: 7.39 GiB used: 3.87 GiB (52.4%) Shell: Bash inxi: 3.3.28

The recommended method to install nvidia drivers is to use mhwd

sudo mhwd -i pci video-nvidia

You already use the latest nvidia for your gpu.

The search function will show you other topics with the same objective

The video-hybrid-intel-nvidia-prime driver should contain the necessary tools to switch.

I don’t own system like it so I won’t be able to tell you how to use it - a quick guess

prime-run </path/to/app>

you can use prime to run single applications on nvidia gpu or you can use optimus-manager to switch to nvidia as permanent primary gpu.

i would recommend to use optimus because i think everyone who buys a laptop with an external gpu wants to profit from their better performance and isn’t interested in a lame-duck of internal intel-graphic.

Exactly!, good info thanks
Which of the following options should I use when installing optimus-manager ?
Choose optional dependencies for optimus-manager:

1:  bbswitch: alternative power switching method
2:  acpi_call: alternative power switching method
3:  xf86-video-intel: provides the Xorg intel driver

I guess since this is an intel machine, I have to choose 3

I installed it but it doesnt work out of the box. Will have to read up

]# optimus-manager-qt
QStandardPaths: runtime directory ‘/run/user/1000’ is not owned by UID 0, but a directory permissions 0700 owned by UID 1000 GID 1000

The last 20 years, anything troltech produced always had problems. So it must be a usual QT bug. The Cli version of optimus does not seem to install so I am a bit stuck.

I managed to get it working.
Optimus-manager managed to start once and I got an icon in the taskbar where I could set the startup video card as Nvidia.
I rebooted and at least now Nvidia is working, and I get 77fps with heaven benchmark.
10x more than the stupid integrated intel card.

However, it is impossible to start optimus again or to get the taskbar applet for settings.
optimus-manager is not working right in a clean manjaro install and is buggy as hell, but luckily it worked once and helped me switch to nvidia before it permanently went to bugland.

Thanks all for helping. I am very grateful

optimus-manager is buggy, yup. then why use it?
Its much better to learn to use prime-run.

True, but at least it did manage to solve my problem before it went to happy hunting ground.
I will make a note of prime-run for future nvidia instsalls thanks.

How it didn’t work? What did you expect? I’m not sure if you realize, but this is a hybrid setup by default, so it will use Intel/AMD for everything unless you specifically run an app with Nvidia card. It doesn’t happen automatically on Linux, because hybrid graphics were never designed for Linux and Linux cannot do that automatic switching. However, in some Vulcan or Proton games, they will use Nvidia automatically, since Vulcan will use Nvidia always in hybrid setups (if everything is working correctly).

As @cscs said, you need to use prime-run variable before any run command to have a program be using Nvidia. You can embed it in the launch option, so it will do that every time you launch a certain app.

Every graphics and video intensive application I tried so far always use the Nvidia GPU as things are now way faster and frame rates are way above what I used to get with the intel junk GPU. Approximately 10x faster

So Optimus switches Nvidia permanently as primary as I confirmed and which someone above pointed out so i dont understand the problem you perceive.
I definately do not want hybrid operation so I selected dedicated nvidia from optimus, and that sure works well

…you are missing the point.
Youve gone and used some other utility to set it to nvidia-only.
But the way it would have worked already was iGPU by default, and dGPU when called.
Thats not a ‘problem’. Thats how it is supposed to work.


glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

Hello, guys are right, apparently you almost understand, when you want to use Nvidia, you should create program shortcuts, something like this. Only instead of primusrun, you will have prime-run. Try to run and make a shortcut

Re " [cscs]
…you are missing the point. "

Maybe supposed to work that way, but it clearly didnt. It refused to switch to NVIDIA automatically when I used GPU intensive applications.
So what I describe above for a solution is perfect form me. I just want to use NVIDIA period and not have to deal with this obviously buggy automatic switching between built in and nvidia gpu.

I understand the automatic switching is important for battery powered equipment, but that is not my need, so I prefer NVIDIA on all the time and not have the irritating low frame rates for no reason.