Numlock (keyboard) issue on bootup

Need to have numlock start on boot up, can fix in Linux Mint 20.1 and Zorin 15.3, but here I can’t, new to this distribution and ask for assistance in how to write in terminal

Hi,

It is in System Settings > Input Devices > Keyboard

1 Like

Hi,
Open /etc/sddm.conf with Kate

[General]
InputMethod=
Numlock=on

2 Likes

You can simply turn numlock on (keyboard) and reboot … just like Windows has always done

There’s a short way to do this.
Just turning it on doesn’t mean it will always be on at startup.

So you have two menu’s - either krunner (either hit Alt_Space, or if you’re on the desktop just start typing ‘keyboard’) or the normal launcher (hit Meta key and type ‘keyboard’).

NumLock on Plasma Startup has 3 options: ON, OFF and UNCHANGED.

Select ‘Turn On’ and don’t forget to hit ‘Apply’ in the bottom right corner.

1 Like

Just turning it on doesn’t mean it will always be on at startup. … this works in cinnamon

But not in Gnome and Plasma.

did not work

Tried to figure it out but since I 'm a newbie by Kde Plama wasn’t able to complete task

Nope didn’t work

Did that and still not on during bootup

Thanks for everyone with your suggestions, will keep checking back to see if someone figures this out for me, again thanks for your input.

All was said already above.

You have to select Numlock activated in Plasma preferences and to edit etc/sddm.conf and change the default setting from Numlock=none to Numlock=on.

I have tried and still refuses to activate on bootup

I want to thank everyone trying to help, I needed Numlock to work on boot-up, I can see in this distribution this option needs work. I’ve decided to remove this distribution and look for an alternative Linux one. Thanks, will check back after a new release rolls out and see if issue has been resolved.
Thanks again, bfn.

This is how I do it:

Step 1: System settings → Input Devices → Keyboard → Hardware → NumLock on Plasma Startup (Turn On)
Step 2: Terminal → nano /etc/sddm.conf
EDIT:

[General]
Numlock=on
1 Like

It works fine in Manjaro, it’s just a few clicks in system settings. I’ve been using plasma for years and that’s all that’s ever been required.

1 Like

Just set it properly in Plasma settings (don’t know why other people tell you to modify sddm.conf it never was needed on the dozen KDE installation I made, maybe it is required to be enable before the user login though, I auto login so I don’t know).

If it doesn’t work then you’re doing it wrong, you’re trolling (which seems like it regarding your post “ho I can’t change a setting so I will use another distribution that works”), or something else in your system forces things.

I selected the solution for you as everything has already been said.

2 Likes

You’ll try to use another Linux because you’re having a problem with Linux?

That really makes sense.

However, I think you should go. Everyone here has said that (with KDE) you simply load up ‘keyboard’ from the menu and select the ‘Turn On’ Numlock on Plasma startup.

It works for everyone. It always worked for me, and I reinstalled a few times.

If it’s not working for you, that’s because you did something that messed up your system - you can try creating a TEST user to see if the problem exists with that user, you could back up your stuff and try a fresh install.

However, I already have a TEST user (with zero settings - just like a fresh install) for testing issues I had with software. TEST user gets Numlock at boot - there is no issue with Manjaro, there is no issue with Linux.

So yes, bfn. We don’t need this :stuck_out_tongue:

I had te same. I set the preference but nothing changed. As soon as I edited the file too I got what I wanted.