Numeric keyboard never works

hello everybody,
I’ve problem with my calculate (numeric) keyboard , it hadn’t never been worked since i used manjaro xfce, it only works when I login into xfce session, then, numlock is open but no keys work.

Do you have numlockx installed? If not, you can install it like so… :arrow_down:

sudo pacman -S numlockx

For tty sessions outside of the graphical environment, you can install systemd-numlockontty from the AUR.

pamac build systemd-numlockontty
sudo systemctl enable --now systemd-numlockontty

If neither of these two approaches help, then perhaps the problem lies with your keyboard itself ─ i.e. a hardware issue ─ or else you have chosen the wrong keyboard layout.

In the latter case, you can select a different keyboard layout in the Manjaro Settings Manager. You may need to try a few layouts (and their respective variants) before you find one that matches your actual keyboard.

1 Like

@Aragorn
yes I installed numlockx before but it didn’t help at all, I tried to use the another solution (numlockontty) and I got "Failed to enable unit: Unit file systemd-numlockontty.service does not exist."
It can’t be a hardware problem because I can user the calculator while login and in windows OS too.
I also tried to change the layout a lot, now I’m using “dell 101 key pc” layout and it’s identical with main (I’v searched for pic).

I would recommend trying the generic pc101, pc104 or pc105 variants instead of the Dell variant.

Also, unless you have an older type of keyboard without Win-keys, you’re probably not going to want a pc101 layout.

Mod-edit: Spelling and link to product

@Aragorn
no, didn’t help also :((, Tried all generic layouts, ps. my keyboard is a lenovo IdeaPad Gaming 3i (15) keyboard.

Edit /etc/lightdm/lightdm.conf to activate numeric keyboard before loggin : NumLock on by default

I didn’t find the greeter-setup-script=/usr/bin/numlockx on in the conf file, so I added it by myself, but also it didn’t help

May you share your conf file?

here it’s, notice I’m the one who added numlockx on
justpaste*it/28rje
please replace * with .

ok, the property “greeter-setup-script” is line 119 :

  • uncomment the line by deleting the “#” caracter at the beginning of the line
  • add the value : /usr/bin/numlockx on
  • save the file
  • restart your computer
  • test the numeric keyboard on loggin

didn’t work too :(( it’s only work when I write my password, then when I login It doesn’t

what is the output of : xfconf-query -c keyboards -p /Default/Numlock

true
[saleh@schostakovich Desktop]$ xfconf-query -c keyboards -p /Default/Numlock true

Your bumps have been deleted.

https://wiki.manjaro.org/index.php?title=Forum_Rules#Bumping