NTFS Drive - write permission on Manjaro KDE

I just click on my drives on file manager and it mounts automatically… dont know about ro or rw.

Check if ntfs-3g is installed on your system. If it’s not, install it from Manjaro repository.
There are three things to do in your fstab.

  1. Mount your ntfs partitions to remove the potential locks, like so

      /dev/sda1	/mnt/<folder_you_created_1>	ntfs-3g	remove_hiberfile
      /dev/sda2	/mnt/<folder_you_created_2>	ntfs-3g	remove_hiberfile
      /dev/sda3	/mnt/<folder_you_created_3>	ntfs-3g	remove_hiberfile

    (i assume your ntfs partitions are /dev/sda1, /dev/sda2 and /dev/sda3, but it can be different, check with lsblk in console)

  2. In console, do : sudo mount -a, then umount these 3 partitions.

     sudo umount /mnt/<folder_you_created_1>
     sudo umount /mnt/<folder_you_created_2>
     sudo umount /mnt/<folder_you_created_3>
  3. Then comment out these three previous entries in fstab and mount them normally, like so :

      /dev/sda1 /mnt/<folder_you_created_1> ntfs-3g gid=1000,dmask=007,fmask=007,noatime,nosuid,nodev,noexec 0 0
      /dev/sda2 /mnt/<folder_you_created_2> ntfs-3g gid=1000,dmask=007,fmask=007,noatime,nosuid,nodev,noexec 0 0
      /dev/sda3 /mnt/<folder_you_created_3> ntfs-3g gid=1000,dmask=007,fmask=007,noatime,nosuid,nodev,noexec 0 0

(I assume the group id of your user is 1000).

sudo mount -a

With fmask=007, you will have -rwxrwx— permission for files
and dmask=007, you will have drwxrwx— permission for folders.

You can change them of course, and now your partitions will be well mounted at start.

1 Like

@Mayanktaker What were the results in the above steps from earlier?

You can have read/write permission only with ntfs-3g, otherwise you only have read access

1 Like

The problem is we still don’t know if their NTFS file-system is marked as “dirty”. That’s why it’s good to find out why it keeps being mounted as read-only. Sometimes ntfsfix is enough to correct this. Other times it requires a full check disk from a Window PC. :worried:

When my NTFS file-system is marked as dirty, ntfs-3g still mounts it as read-only, even when explicitly invoking the “rw” mount option. Scanning / fixing the file-system (either with ntfsfix or using Windows) is the only way to safely get it to allow read-write access under Linux.

If one wants to have his Windows 10 disk available in Manjaro, he needs to disable the feature in Windows 10 and reboot.

Unfortunately, they do not have access to a Windows PC. I believe these are external drives?

From a pure-Linux environment, I can only hope that “ntfsfix” is enough to correct any underlying issues without requiring a full check disk from a Windows PC.

This is only related to dual booting, re-read the initial post please, it’s completely out of scope and you are provoking confusion for the OP

As far as i know it was not the original issue.
If the OP mount with ntfs-3g, we’ll see.
You are over complicating things.

The proper way though is to use Windows 10, unfortunately, if these Windows features have been left enabled on the disk.

1 Like

I’m not. I provided troubleshooting steps for a common NTFS issue, then you interjected into the thread with extra commands and redundant steps involving uid and gid. We don’t even know if they are internal or external drives, but why assume these were all internal drives used with hibernation? A more likely case is they are 3 external drives formatted as NTFS back when they used a Windows PC. We’re still waiting for the original poster to clarify this for us. (Or they’re all internal in a desktop PC, still waiting on the OP.)

ntfs-3g does not need to be explicitly invoked in order to mount an NTFS file-system with “read-write” permissions.

Simply using the mount command is enough:

sudo mount /dev/nvme0n1p4 /mnt/ntfs

Yields this:

/dev/nvme0n1p4 on /mnt/ntfs type fuseblk (rw,nosuid,nodev,user_id=0,group_id=0,allow_other,blksize=4096)

I have full read-write access to my NTFS partition.

Using Dolphin file manager (as the OP did), simply clicking on the NTFS file-system yields full read-write access as well.

However, if the NTFS file-system is marked as “dirty”, it doesn’t matter what options you include in your mount command, and it doesn’t matter if you manually invoke ntfs-3g. It will still be mounted as read-only in order to protect the NTFS file-system.

Here is a similar thread for reference, in which ntfsfix was all that was needed to resolve the read-only issue:


So let’s wait on the OP for clarifications. They did not yet provide the output from the previous commands which can hint to what the underlying problem is.

1 Like

The simplest solution here is too mount the disks as read only, copy the content to another drive, usb thumbdrive or usb harddisk or wathever. This way you don’t have to deal with a dirty ntfs filesystem.

but i agree with others that it is better to let Windows fix the filesystem first but since you don’t have access to Windows any more this is a viable option.

1 Like

Even if you don’t have Windows installed you can use Hiren’s BootCD - which is a Windows PE rescue environment - read more in this topic

Because you can have those read only locks even if you did not use hibernation in Windows man…

Re read what i wrote related to ntfs-3g and you will realize you understood the wrong way.

And who cares about “dirty” bit for the moment as you don’t know if it’s the case.

We definitely do not need any Windows installation in order to mount any partition, ntfs or whatever filesystem.

I told the OP to use ntfs-3g to have read/write permission on his partition.

As far as i know, you did not help him to resolve his issue, because if he follows what you wrote in all your posts, the OP will only have read-only, this is therefore irrelevant…

I missed the post where the OP did those steps and replied with the error message of why the file-systems were mounting as read-only and whether or not ntfsfix was enough to resolve the issue (as it has been with other users.) Can you link me to the OP’s reply where they followed-through with this, so that we can quickly rule it out and move on to the next steps? Thank you.

Even with ntfs-3g, RO can occur, as has happened to my drives (SATA and USB) when I have used Windows (no fastboot, hibernate or sleep and not dual-boot) and then Manjaro. All drives became RO. It’s not every time, but sometimes. The solution was to reboot into Windows and then back to Manjaro again.

My Windows is on a separate SATA HDD, and is not even in GRUB, but the problem can still occur with other SATA and USB drives after using Windows.

I think that @Mayanktaker could install Win 10 ISO on a virtual machine, turn off fast boot, mount the drives on that. Shut down the VM and try again. Alternatively, try the drives in a trusted friend’s/relative’s Windows machine.

Cant reply everyone so writing this -
I have one more SSD and I installed Windows 10 on that and when I installed Manjaro and Windows both, every time I unplugged my other Hard Drives for safety and I do this everytime I install an OS. So I tried booting to Windows and then Manjaro but no luck. I fear if those commands break my hard disk or I fear of data lose. I cant lose data. 3 TB of data. Cant move from those drives to other place because I dont have more memory.

I tried with Ubuntu live and Manjaro live, no luck. in my main Manjaro, no luck.
Run few commands you guys suggested but no luck.
This is the only thing stopping me to use Manjaro full time.
For now I have to use Windows again(sadly).
Still searching for proper solution because I have 6 computers which I want to replace totally. But looking at current conditions, I think Windows is ready to eat if peal properly.

Update :
sudo ntfsfix command did the trick and fixed errors. I used this command with all three partitions and now I have full read/write access to my HDD.
Thank you guys for your time, your help and your kindness.
I really appreciate it. Now I can enjoy Manjaro. <3 :heart_eyes:


That’s great to hear!

However, be diligent and cautious with NTFS. You might not be entirely out of the woods yet, as @bikehunter666 implied (I think?) that longterm your best option might be to copy your data to another drive formatted in a more “Linux-friendly” file-system, such as EXT4 or XFS. This way you won’t have to worry about using a Microsoft file-system on a pure Linux ecosystem, nor rely on booting into Windows 10 to fix deeper NTFS issues, should they ever occur.

Just remember the risks involved with moving large amounts of data without any backups or redundancy. The choice is yours! Good luck, @Mayanktaker! :v:

1 Like

Jep longterm solution would be to use ext4

1 Like